Schitt Modi Multibit not detected (again)


Not sure what is happening on my Roon setup. My Windows PC is unable to detect my Modi Multibit DAC via USB for past few weeks. I am able to connect this DAC (via USB from Windows PC) directly to my speakers and it works.

I had similar issue last year on this Schitt Modi connection, Roon was not able to detect it initially. We resolved it by disabling Windows Defender Firewall and Avast Antivirus and restatrting Roon. I tried this a few times but it did not work this time. I also reboot the computer and reinstalled Schitt drivers but did not work.

Any suggestions to troubleshoot?


Thanks for reaching out, @spiderjoe, and apologies for the difficulties here!

Are any other local endpoints appearing correctly in Roon?

Have you tried using a different USB cable?

Just to verify, do you currently have exceptions in place for Roon and RAATServer here?


Was there a recent Windows update?

1 Like


No exceptions in place for RAAT server

I have three other end points - two Bluesound modules and a Lumin Streamer, all three are visible and works.

Yes problems started after a recent Windows 10 Update.

No, I have not switched USB cable, Don’t think problem is with usb cable. Windows can detect the Schitt Modi Multibit and playback audio through this DAC with the existing USB cable

Hey @spiderjoe,

You’ll definitely want to place an exception in your firewall for RAATServer so that the connection is not blocked.

If that yields no change, please try the following:

  • Before anything, please create a backup of your current Roon database.

  • Once you’ve created the back up of your Roon database please close all active instances of the application and reboot the machine hosting your Roon core.

  • When the machine hosting your core is powered back up I would like you to please test with a new RAATServer folder in place.

    • Your “RAATServer” folder will be in the same directory as your Roon database
    • Rename the entire RAATServer folder to RAATServer_old

Once you have renamed your “RAATServer” folder to “RAATServer_Old”, please relaunch the application, and confirm if you are still experiencing the issue.


Thanks for the steps.

I placed exceptions on firewall - did not work.

Next, followed your steps yo rename RAATServer to “old” and now it works.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.