Screen turns black when I start search using Wine 4.6

#1

Core Machine (Operating system/System info/Roon build number)

MacOSX on MacBook, Roon 1.6 (build 416) 64bit

**Remote
Windows 10 and Roon 64bit
Linux (Ubuntu) with Wine 4.6 and Roon 64 bit Windows
Android

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Allo DigiOne

Description Of Issue

Everytime when I click on the search icon in the upper right corner of the Roon remote, the screen turns completely black except for the white search entry field. The screen stays black, whatever I do (enter search, press escape).

The only way to get rid of the black screen is close the Roon application and restart. After a restart Roon shows the search results of the search I have entered before the restart.

The issue only happen with Roon remote on my Linux configuration (see above). When using Win10 or Android remote evrything just works fine. The issue started after the latest Roon update. Before I could just search and find my favourite music.

I know Roon remote is not officially supported on Linux. But I hope anybody can give me a hint on how to solve this. I already tried a complete fresh install, but it failed to solve the black screen.

(Daniel Beyer) #2

Try the 32 bit verion

#4

Thanks for the help. Tried it, but running Roon remote 32 bit version does not solve the issue.

#5

This could be a graphics driver issue. I never had this problem on my Ubuntu 18.04 LTS (with HWE enabled) using the integrated graphics of the Core i5-6400T.

#6

Thanks, I will dive into the direction of the graphics drivers. Maybe an update of the graphics drivers is causing the problem. I also never had any problems on Manjaro. And except for search, everything is running smooth.

#7

Managed to solve the issue :upside_down_face:
The solution was downgrading Wine from version 4.6 to 4.2.
So the issue was caused by an update of Wine and not an update of Roon; they just happenend around the same time.

@Rugby and @BlackJack : thanks for your support!

1 Like
#8

Had same issue here, didn’t bother trying to resolve. I’m sick of working around Roon shortcomings like lack of a native Linux client in 2019.

(Daniel Beyer) #9

Thanks for posting your solution.