Screensaver up next issue [solved]

I noticed that the Screensaver screen (ctrl + s) only shows the “up next” information after Ive opened up the queue window (by clicking on the artist/title in the playback window at the bottom).

Should be easy enough to reproduce:

  1. Open Roon
  2. Play a list of songs (e.g. Play all tracks)
  3. Open screensaver (ctrl + s)
    => up next info missing (expected behavior is present)
  4. Close screensaver
  5. Open queue window (e.g. by clicking on the artist / title in the playback bar at the bottom)
  6. Open screensaver again (ctrl + s)
    => up next info present

Thanks Bart!

@Eric @Mike I’d noticed this too, but didn’t have a reproducible case. Needs a ticket.

1 Like

There is no screensaver in Roon. To what are you referring? (:grin:)

1 Like

I know the terminoly might come across as confusing. However, I’m simply taking over the terminoly used by roon (check ctrl + s under keyboard shortcuts in the settings menu).


Until I read this I had no idea this screen existed. So much can be done from here.

Is the only way to get to this is CTRL-S?

From the queue click on the [ ] symbol on the right above the radio area.

Thank you. I really need to get out more… :sweat_smile:

1 Like

Interestingly enough, I don’t have that issue. Ctrl-S works as it should and the Theater View / Screensaver is always showing the “up next” information.

1 Like

I am noticing the same as Daniel (@Rugby ), regardless of where I activate Theater View / Screensaver, I am always seeing the “Up Next” icon on the right hand side. @Nepherte can you please provide a screen grab highlighting this issue as well as giving some insight as to what your setup is like and what you are working with?

Thanks everyone! :sunglasses:


Hey Eric,

I can reproduce. I’m running Roon Server on my Mac Mini. When I run Remote on the Mini or my iMac, I can make it occur.

Follow Bart’s @Nepherte instructions, but make sure you Quit Roon Remote first!

It seems to fix itself after you go into the queue and open the screensaver. After that, if you go into, say, Album View and press cmd-s, it works as expected.

Cheers, Greg

1 Like

Then it might be a Mac issue, since it is working as expected on my Windows boxes. Are you on Sierra?

Well, the core is on the Mini with El Capitan, with Roon Remote on the same machine.

iMac with Roon Remote is Sierra.

Happens on both machines.

Cheers, Greg

@Greg — Thanks for the tip! I can indeed confirm the same observation :clap: I will discuss with my team and take a ticket out. Thank you EVERYONE for your feedback!


For sake of completion, I am using a setup similar to Greg’s: Roon Core + Roon Remote on the same machine (Windows 10).

1 Like

Thanks for clear steps, ticket is in.

This one is fixed!