Scroll postion still not working on iPad [Resolved with Roon version update]

I can confirm that this is indeed an issue.

@Support? 10char

Having the same problem.

Hey @Dave_Richardson,

Thank you very much for getting in touch about this - I’m sorry that you, alongside @Arlen and @Bob_Brinza, are experiencing this issue. We’d love to help out :nerd_face:

To that end, we’d love to find out more about it to understand exactly what is going on. For example:

  • what is the screen you’re starting on
  • what screen are you going back from to get to the screen you started off on

Also, you mentioned coming back to the Roon Remote app. Are you simply switching to another app, or quitting the Roon Remote app (swiping up from the app tray)? How long are you doing other things until you return?

Any relevant screenshots would help a lot.

Thanks in advance :pray:

My control point is an iPad Air(3) running iPadOS 14.6. Roon is 1.8.806.

List My Albums:

Scroll through the list and choose an album:

I chose Arvo Part: Piano Music.

The album is playing, so I switch to another app. The following screenshot shows Roon as an ‘active’ task.

When the album is through playing:

I go back expecting to be in the album list where I chose the Arvo Part album. However, I find I’m at the top of the list again.

The only way I’ve found around this is to build a queue–add an album to the queue, go back, find another album to add, etc. When the queue finishes, and I haven’t moved the list from the last album added, the list remains positioned.

Hope this helps.

1 Like

Hi Rebeka,
Thanks for getting back to me. To answer your questions in order, I’m starting out in My Albums. When I go back to My Albums it’s by using the back arrow from the Queue. When switching to a different app from Roon I would double click the Home Button on my previous iPad. On my current one I do a three finger swipe on the Magic Keyboard Trackpad. If I only do other things for a minute or two before coming back to Roon with a three finger swipe or choosing it from the app tray, every thing is fine. If it’s any longer than that is when I run into problems. This is what my screen captures are trying to show.

  1. Start someplace in My Albums.
  2. Play a selection from there.
  3. Do something else while the music is playing.
  4. If I do something else for more than a minute or two when I come back to Roon I get a quick Roon animation before the program opens again.
  5. Using the back arrow from there takes me back to the beginning of My Albums, not back to where I left off.

1 Like

Thank you both @Bob_Brinza and @Dave_Richardson for sharing in such detail the steps you’re taking when you’re experiencing this behavior. It is awfully similar and might point to the same issue.

Before diagnosing or making and suggestions for next steps, I’m looping in our technical team so they can take a closer look :nerd_face:. This thread is now with them :pray:

1 Like

Thanks for your help.

1 Like

Hi @Dave_Richardson

Our team is looking into this and I just had a couple of questions that’ll help us better understand what might be happening here:

If you do something else quickly, say for just 30s, does this same thing happen? Does it seem to be based on how long or how much you’re doing while Roon isn’t running?

Just to be clear, are you closing the Roon app, or is it running in the background?

Hi Dylan,
In response to your questions I did a little research. My initial impression is that if I come back to Roon while the first song is playing, no matter how long it is, I don’t get the Roon animation and when I back arrow to My Albums I end up at the spot I left off. If I do other things long enough that the second song starts to play, I get the animation when I come back to Roon and a back arrow from there takes me to the first album in my albums instead of where I left off.
I do a three finger swipe on my Magic Keyboard to hide Roon so I can switch to another app which I believe is leaving it running. If I do another three finger swipe with a little jog to the right Roon is always there with whatever other apps are running.

Just some additional info, I’ve discovered it happens during the first song occasionally as well.

Not sure of the timing of this getting fixed as I first reported it 4 years ago but for what it’s worth, the most recent update didn’t change anything.

Thought I’d dredge this topic up again to point out the the most recent update has finally taken care of this problem. Thanks.

Hi @Dave_Richardson

Thank you for following up to let us know that this issue was cured with the latest update, that’s great news! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

Unfortunately it has not been fixed, Roon on iPad reloads if using other app and then looses scroll position. This has been case for a long time…

Hey @ds_2 ,

We’re sorry to hear that you’re still experiencing this. Can you please ensure that you’re running the latest update, Version 831?

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

We’d be happy to take a closer look at this for you!

I first reported this back in 2017 and was pleased to finally have it fixed. You do need to be running the latest version on your iPad as well as your core. Also, did you turn on Enable Lock Screen controls under Settings/Setup on your iPad? You have to do it there and not on your core.

1 Like

Guess support is going to have to give you a hand. I use my iPad exclusively for my remote and for the last 4 years it has behaved exactly as you’ve described. Until yesterday when the problem went away. I can pick something out of my album list and play it, go do something else for a while and when I come back to Roon and back arrow to my albums it goes back to where I was instead of back to the beginning like it always used to. I notice in the feedback thread on the update that a number of people have the same change I’ve experienced so you must have something else going on. Hope Support can help you get it resolved.

1 Like

Yes my experience is exactly the same as @ds_2 over the last couple of years of using Roon on an iPad.

I am away at the moment so I don’t have the latest update installed yet, but I will be very happy if the iPad app finally stops getting wiped out of memory.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.