Search Win 10 On-screen keyboard conflict

Roon 1.5 (build 323) stable (64bit)
Windows 10 Pro, Version 1803, OS build 17134.48


  1. click search icon (roon)
  • Windows on-screen keyboard appears.
  1. click search icon again
  • roon search box appears.
  1. type a letter in the search box.
  • Windows on-screen keyboard exits.
  • roon search box exits.
  • no search conducted in roon.

also, not releted to problem, tried to upload png file then jpg file and got this error on screen: uninitialized constant EXIFR::JPEG.

Thank you for your report, @Gary_Thomas!

I tried this myself on both of my Windows 10 devices, and was not able to replicate the issue, so I was hoping to get a bit more information from you regarding the behavior you are seeing.

  • Has this always happened? Was there a recent Windows update that changed this behavior for you?
  • Does this happen in other areas of Roon? What about other applications?
  • In Settings > Setup do you have Enable On-Screen Keyboard active?
  • Since noticing this behavior, have you tried rebooting your PC?
  • Is this device your Core machine, or just a remote?
  • Can you please provide the exact make and model of the Windows 10 device you are using?


  1. this has not always happened. Could have been caused by windows or roon update.
  2. have not seen this in other areas of roon - only when clicking the searh icon (top right)
  3. Settings >> Ease of Access >> Keyboard - all toggles are set to ‘Off’
  4. Yes, but to be sure, I just rebooted. OK. there was a change.
  • click search icon and the keyboard and the search dialog appears.
  • i can now type and search - When I start typing the on-screen keyboard exits.
  1. Just a remote
  2. Intel Nuc Skull Canyon - Intel i7-6770HQ @2.60Hz 2.59 GHz
    16GB Ram
    64-bit operation system, z64-based processor
    Pen and touch - Pen support

Thanks for the information, @Gary_Thomas!

I’m passing along this information to the technical team to see what they can come up with in house. I’ll be sure to keep you updated on their investigation here.

In the meantime, can I ask that you please verify one thing for me? In Roon, under Settings > Setup do you have Enable On-Screen Keyboard active?

Thank you,

Why yes! That roon setting is enabled! Don’t rember turning that on.
Looks like that fixed my problem. Thanks.

1 Like