Second Pi running XL with configuration issues

Hi Harry,

I added a second Pi 3B to my network today and it’s having problems being detected correctly. I have been trying to get this second one to run over DLNA. The new one is at

I submitted feedback 49b1fc6415e0d45d.

At the touchscreen, it’s reporting Connection Failure. It is however seen and configurable within my web browser at ropieeexl.local, along with my other Pi. It is not seen as an available endpoint within Roon, but Roon is aware that it is on the network and running (seen in About).

Please let me know what your recommendations are for proceeding. Thanks, David

How did you create it? Did you get a new image?

I’m not entirely sure what you mean with ‘being detected correctly’ as you mention that is is visible in Roon. Does it play audio?

As you mention the screen: have you enabled the RoPieee extension within Roon?

Furthermore I see that you did not configured the zone to be controlled from the display, so that’s also preventing it from working.

Hi Henry. Yes, I downloaded and wrote a clean image to a separate SD card.

Harry, I mean Roon sees it and lists it in About, but the device doesn’t appear in the zone/endpoints in the Audio section.

I’ll check. I wasn’t aware about the need to enable the extension. This is my first touchscreen unit.

Still confused. You state that you’re using it for DLNA, but are taling about visibility in Roon.
Keep in mind that if you use it for DLNA the device is locked and Roon can not control it. That also prevents it from being visible in Roon.

Hi Harry - thanks. I have probably misunderstood a few concepts or terms along the way. Thanks for your patience.

I had assumed Remote Control was for handheld remotes. It never occurred to me that a touchscreen would be considered a remote. I enabled the remote control extension in Roon. The output on the touchscreen is different now - It says “Zone not Found”. I will probably need to go back to read Roon documentation on Zones again, because it does not appear in Roon as a zone.

Within RoPieeXL configuration, on Remote Control tab it still shows Remote Control = None.

On the Display tab Roon Control Zone = Unknown.

Thanks, David

These are 2 separate things:

Remote Control is indeed for handheld remotes like a Flirc.TV.

You need to enter the zone you want to control/display into the ‘Roon Control Zone’ field of the Display tab.

You’re almost there :wink:

OK - I’ve renamed the device from the default name and rebooted. I turned off the Remote Extension since it’s not relevant to the task at hand. I added “MusicBeastRoPieee” as the Roon Control Zone and rebooted. I’m back to “Connection Failure” message on the touchscreen.

the Remote Extension is required for the display (as is also mentioned on the display)

OK - will turn it back on.

I think I’m going to try a clean reflash of the SD card and start over. The remote control is still not detected within the RoPieeeXL configuration options. Roon still only sees my original zone.

While I’m waiting, to the point of your earlier question, yes, I’m considering a post-Roon world and looking for a solution that uses my existing UPnP/DLNA servers. I’ve not had luck with the other distributions I tried yesterday. The closest I got was with MoOde yesterday seeing them, but the mpd configuration options eventually defeated me.

OK - I went back to the online guide and was more careful to follow step by step instructions. My main problem was that I had left the default setting of No HAT in place. (I’m experimenting with this set up before I consider migrating over my Digi+ from my existing headless RPi to the Pi with the touchscreen.)

Once I enabled Raspberry Pi DAC as the Audio HAT, then Roon showed me the ALSA device and gave me the option to configure it. Then I could name the zone and populate the information into Roon Control Zone in the Display tab.

I believe this resolves my major issues. I’ll provide updates later should I have more problems.

Thanks, David

OK - I have successfully played to the touchscreen zone from Roon. So, I know the solution is possible with this hardware (minus HAT).

Another thing I didn’t understand was that this option is still, at root, tied to Roon and Roonbridge. If I want a post-Roon solution, I need to keep looking.