Seeing the following error message while playing back DSD content: "An audio file is loading slowly" [Resolved]


I am encountering a problem with Roon 1.3 (build 234).

I have a DSD265 album (Hope by Robert Len and Carole Meneghel). I am on an iMac which supports up to DSD128. My music folder in on my iMac’s native SSD drive.

When I attempt to play the album I receive the message: “An audio file is loading slowly …” I believe this has started occurring in the latest build.

This problem occurs on multiple Roon endpoints: PS Audio Stellar Gain DAC and a Moon 230HAD.

DSD playback strategy is set to “DSD over PCM”

If I change the DSD strategy to “Convert to PCM”, the album plays without error.

Thinking that the folder might be damaged, I replaced it from an archive. Same problem.

I swear it worked before the latest update. :slight_smile:


Hi @James_Warnes ----- Thank you for the report and sharing your observation(s) with us. The feedback is appreciated!

Typically, this error message (“An audio file is loading slowly …”) you’ve mentioned, would indicate that there is some sort of “bottle neck” occurring somewhere in your setup where information is not being pulled or received quickly enough.

In light of this, would you kindly please provide the following information, to help aide in my evaluation of this behavior. Please see below.

  1. Can you please provide us with the specs of the iMac hosting your Roon core.

  2. Describe what the chain of communication looks like across your setup. I want to have a better understanding of how your endpoints are being accessed in your network.

  3. While this may seem elementary :innocent: how are you doing on storage space (“My music folder in on my iMac’s native SSD drive”)?

  4. Please provide a screenshot of your signal path when you notice this behavior.

  5. During your troubleshooting of this issue, have you tried experimenting with upsampling PCM content to DSD256/DSD128? If so, what was the experience like?


Hi Eric,

Apologies for the delay but work got in the way.

First, here’s the message:

Here are answers to your questions:

  1. System Specs

System utilization with Roon running:

  1. Chain of Communication. Is this what you are looking for? I’m not sure because question 4 is asking for this info.

  1. Storage Space

Lot’s of free ssd space available:

  1. Answered in response to question 2.

Here’s a bit more data. In this case, the album plays flawlessly. DSD -> PCM

and it plays flawlessly here. DSP engine disabled.

  1. Upsampling

Is this what you want me to try while playing a 44.1/16 recording?

No problems encountered.

And finally, my problem only happens with a DSD256 album. DSD 64 and 128 are not .a problem.



Hi @Eric - while what you say is true, I couldn’t help noticing in the first Signal Path screenshot posted by @James_Warnes that the Processing speed is shown as 0.7x. This would seem to indicate that his iMac doesn’t have enough “umph” (technical term) to handle the DSP. Could this be the cause of the issue?

Hi @Geoff_Coupe ---- Thank you for the heads up! I must’ve missed that in the screenshots.

@James_Warnes this very well could be the cause of the issue here. I have a meeting with my team scheduled for tomorrow to discuss and once I have some feedback I will be sure to follow up promptly.


I occasionally get that on my :poop:Mini, but never when I had core on WIN10 with an i3. There just isn’t enough horsepower, Mini i5, for DSD256+ if Mini needs to do something else. Like Time Machine backups, maybe?

Hello, First, I have an iMac 5K, 4Ghz, Intel Core i7, 32 Gb of memory.

So I believe I have a lot of “umph” although I might refer to it as “horsepower”. :smile: I believe I have a lot of horsepower and a lot of RAM. My iMac should never do any swapping to disk.

So here’s another screen shot. It shows system utilization (very idle), it shows that the DSD 256 file is on iMacs native disk (no USB disk) and it shows the Roon processing speed.

Yes, you will see “duplicate” because I’ve copied the file to multiple external disks to see things change.

In terms of network topology, iMac wireless talks to an Apple Time Capsu;e which is connected to a modem.

And once again this “problem” only happens with one file, the DSD-256 one.

Regards, Jim

Let me add that I am a software designer/developer for a database company whose favorite color is red (as in Redwood Shores, CA). :slight_smile:

Part of the job is debugging customer problems. So I’m used to doing a lot of “what ifs”. So after I posted the note above, I disabled crossfeed and the problem I’ve been encountering is gone.


1 Like