Send audio to USB rather than SPDIF

Kind of newbie here, using Raspberry Pi 3 Model B Plus Rev 1.3 with a HiFi berry Digi + Pro HAT, running RoPieeee XL ver 3.020, connected to a NAD M32 using the SPDIF digital output from the HAT. I would like to try the USB audio output instead, but I do not seem to be able to make it work. I suspect there are changes to the RoPieee software but I do not know what they are. Can someone please help? Thanks.

I’m not at home to find it for you, but in the RoPieeeXL software, find the place where you turn on the USB selection. I think it’s under the Roon heading. Then save. You might need to reboot.

Gianfri
This might not be a great idea as the Pi3 shares the same bus with Ethernet so is apparently quite noisey. Jim is correct that in the Web interface you can turn off the hat output and set it to USB.

You might be better going with a Pi4 which has a much improved USB and Ethernet bus.

Mike

Good to know, thanks.
As far as I can tell, the USB Audio is already on.

Set the Hat to blank (or no hat) and restart the Pi.
I think mine is set to no hat, as I think the Hat overrides the usb audio.

Mike

1 Like

It does not. USB works out of the box, independent of HAT settings.

Thanks for the update Harry
Regards

Mike

Make sure the RPi and NAD are switched on and set the NAD to USB input. Then check Roon Settings -> Audio for the NAD M32 and ‘Enable’?

1 Like

I had the same issue. I set Ropieee to “No HAT”, restarted, then went to the Roon audio settings, where the USB output appeared and could be enabled. Then if you turn the HAT back on, both outputs appear separately in Roon. And can play different music at the same time. Not sure if this is what it’s meant to do, but cool!

I’m having a similar issue — Roon does not see my USB DAC, despite turning off HATs and turning on USB audio in RopieeeXL config, perforning numerous Pi and DAC power cycles and confirming that the USB DAC is functioning via PC output.

Should any USB DAC should work? Are there any known hardware restrictions with respect to USB protocol or DAC board? I’m trying with a Mogu F900s — a “ChiFi” DAC + Class D amp with a TPA3116 board. Not sure on USB specs but… Windows 10 can put sound through it.

Likewise, should any IS2 DAC work, or are there known limitations?

Thanks so much!

P.S. I’ve also restarted Roon Core several times — my USB DAC still won’t show as an endpoint.

P.P.S. I see my RoPieee host name (renamed “Greenhouse”) on Roon Settings… About… Roon Bridge. But under Settings… Audio… no endpoint appears.

Out of curiosity, in RoPieeeXL config I turned on USB Audio Output for all streaming platforms. On reboot, a new endpoint showed up for Shairpoint-Sync. I enabled that and tried routing music to that zone. To little surprise, nothing came out. I’ve since clicked off USB Audio for all streaming platforms. Still no Roon endpoint.

I’ve also tried switching from ethernet to a WiFi dongle, suspecting an ethernet/USB conflict on my Pi 2 B. Following Core reboot, same result – Roon sees the RoPieee Roon Bridge, but no endpoint.

I’ve just sent feedback, using the wifi dongle setup:

c60aa747365378d8

Hi,

Unfortunately I did not receive your feedback.
Can you try again (without WiFi dongle)?

Thanks

Thanks Harry!

I’ll have another go with ethernet in my (Indonesian) morning. Meanwhile, here’s take 2 on WiFi dongle feedback:

d8ddc31c6aded171

Can I please also confirm if any USB or IS2 DAC should work, or if you know of restrictions? At present, I’m adding a not-so-hi-fi Roon zone to a work area, so I’m trying for a free solution using the ethernet, Pi 2, DAC + amp and passive speakers on hand. Plan B (for this system, or another Pi on hand) would be to order and try with a consumer USB DAC or a cheap IS2 DAC ported to active speakers. Worth a go??

And for Pi 2, are ethernet/USB conflicts much concern? Would IS2 be the safer bet, despite more fiddling and expense?

Thanks again!

The logs show there is no USB DAC (or device for that matter) connected. Hence it does not show up in Roon.

How is it powered? Have you tried another USB cable?

And wrt to your other questions:

  • if the USB DAC conforms to the USB UAC(2) (USB Audio Class) standard it will work. If it is not working then this is the mean reason: not conforming to the standard.
  • I’m not sure what you mean with ‘any IS2 DAC’. First of all it means you need a HAT (to either output I2S or implement the DAC by it self). The list of supported HAT’s can be found on the website.

Thanks