Server Connection Interrupted

Roon Core Machine

ROON System Status

Serial #54B2038C1444

Operating System

Reinstall

OK

Version 1.0 (build 227) stable

Running 22 hours, 32 minutes, 1 second.

Roon Labs Software

OK

Version 1.0 (build 12) stable.

Running 22 hours, 31 minutes, 55 seconds.

Roon Server Software

RestartToggle Dropdown

OK

Version 1.8 (build 952) stable

Running 56 minutes, 23 seconds.

Roon Database & Settings

Reset

OK

99% of 227 GB available.

Internal Music Storage

Format

OK

4000GB, WDC WDS400T2B0A

100% of 3697 GB available.

Networking

Ethernet

IP Address Setup

DHCP Static IP

IP Address Netmask Gateway DNS Server

Networking Gear & Setup Details

Orbi mesh wifi (DHCP) with Negear Prosafe Switch (GS108E)

Connected Audio Devices

Marantz ND8006 (ethernet to switch) and PM8006

Number of Tracks in Library

81,448 tracks and 15,749 albums. Tidal is my streaming service

Description of Issue

When ever I use the Roon application on my MacBook I receive a “server connection interrupted” message pop up. This will occur every 3-10 minutes. This hangs up finder and usually interrupts the music stream. Sometimes I need to restart the MacBook to clear it fully. If I use the Roon app on either my iPhone or iPad I don’t have any issues.

image

Is your Core on the MacBook? If so where are your media files? How are these connected to your network?

The server connection disconnects are managed by the OS, not Roon.

The core is on the Nucleus + that I just purchased. The media files are primarily a seagate USB drive connected to the Nucleus but some files reside on the internal disk drive (that is part of the Nucleus +). The Nucleus is connected to the switch which in turn is hardwired to the Orbit Mesh unit. The Orbi is connected to the main router by wireless.

Looks like the wireless connection is dropping. For testing purposes can you move the nucleus and plug it into the router.

Hi Ged, I did try this last night. I established a direct ethernet link from the router to the Netgear switch and ethernet to the MacBook and Nucleus. I also took other network devices offline (2 Synology NAS units and another laptop). I did notice that it took longer for the first message to pop up (server connection interrupted) but then it continued on a regular basis. I also disabled wifi on the MacBook so as to force all traffic to ethernet.

Prior to purchasing the Nucleus I was running the Core on my MacBook with one of the NAS drives connected as my music source. Under this configuration I also received the connection interrupted message which I put down to a NAS issue. However, If I recall correctly, I believe there was an update issued by Roon (a few weeks ago) and that was the trigger for the error message? Do you know if this was the case?

I also tried setting the Nucleus to a fixed IP address rather than DHCP - no change though.

I’m thinking of completely isolating the Macbook and Nucleus on their own network: Nucleus <=> Switch <=> MacBook. All set to static IP’s and then introduce internet. What do you think?

I’m work in IT so I’m familiar with troubleshooting network issues but this one has me puzzled … so far.

Stephen

It’s worth a try. I’m not familiar with that error message as I’m not a Mac user. Looking around most commonly found on Nas, time machine connections.

Have you tried changing DNS to Cloudflare, Google or Quad 4?

Currently the DNS is provided by my internet provider (Xfinity) and is set to 75.75.75.75. I am familiar with Cloudflare but I’m not sure how your suggestion will affect this issue. Could you provide a little more information.

I did create an entry in the Host file yesterday to “map” the static IP of the Nucleus + with the DNS name that shows up on my network (nucleusplus). This allowed me to ping the name but made no difference to my problem.

I’m willing to try your idea if you can explain the thinking behind your suggestion.

Thanks

ISP DNS is often slow and unreliable, and changing DNS often sorts a number of Roon issues. It’s a quick change, recommend by Roon and quick to implement.

Roon does an inordinate number of DNS lookups, I mean like thousands, often ISP DNS servers are throttled or slow so moving your DNS server entries to a faster entry can speed up ALL roon services.

2 Likes

Okay, I understand. This makes sense as I assume Roon is constantly pulling meta data for all the albums and tracks. I’m not sure if my number of 81,000 plus tracks is considered high but I can see how this would be a drain on the network. I will try this idea later today and report back my findings. I appreciate your input.

Not anymore. Not long ago, in one of the frequent releases, Roon implemented some caching mechanism on its server, and now the number of forwarded DNS queries is very low.

And sure, having a quick DNS sever set up doesn’t hurt, but I can’t really see how this would affect the OP’s problem… the ‘Server Disconnect’ message, which rather points to some internal networking problem, and not something where a faster DNS answer would do anything good.

Stephen, after reading through your several messages on this thread I seem to understand that you have devices connected to a switch, this witch connected to an Orbit Mesh point, which has no Ethernet backhaul to your main router, but is connected via WiFi. Is this so far correct?

I also seem to remember that you mention in some post that you are using XFinity Internet access. If so, is your main router a XFinity-provided box? I ask this, because in the back of my head I remember one or two threads not long ago, where folks reported connection problems on their home networks, which ultimately could be tracked down to be caused by some overzealous ‘advanced’ security setting on their XFinity boxes. A forum search may help to find these threads. But anyway, this is something I would look into.

You are right @Andreas_Philipp1 I’ve been on here tooooo long answering DNS issues, it has changed.
This is the relevant post I think

I run a PiHole on my home network, so all DNS queries get filtered and logged there. When not long ago there were literally many thousands of outgoing DNS requests by Roon in 24 h, this now is down to a few dozens, if that. Batch processes like metadata updates would really hammer the DNS server with above 100 requests por second… Thankfully, this has been resolved, and very effectively so.

Yes, this is one of the threads I had in mind. Symptoms may be slightly different, but I nevertheless would look into this ‘advanced’ security setting on XFinity.

2 Likes

I made the DNS changes as per @Martin_Webster (and flushed the DNS) and I’m 40 minutes without the server disconnect…

There’s no question that I run a complicated home office network (multiple routers and devices with lot’s of segregation) due to business requirements but I have tried to eliminate as much as possible for testing purposes. I have an Xfinity router as my point of entry. In the current setup I run an ethernet cable from the Xfinity router to the Orbi Mesh router and then an ethernet cable (from the Orbi) to the Netgear switch. From the Netgear switch I have an ethernet cable to the MacBook and Nucleus +. So I have eliminated all wireless from this setup (but two routers - I know this introduces lots of questions!)

Depending what happens with the connection I’m going to try this:

  1. Network only the Nucleus, MacBook and switch and then introduce internet. All the other devices will be eliminated in this setup. This setup will bypass the Orbi mesh router completely and connect directly to the Xifinity router.

Thanks for the feedback - I’ll keep everyone updated.

4 Likes

I am pleased to report I’m nearly 24 hours into the latest settings change and no problems!

I updated the DNS on both my Orbi mesh router and MacBook to 1.1.1.1 and 8.8.8.8 and added a third entry from Xfinity. I was not able to change the DNS on the Xfinity router (option is blocked). Also the advanced security settings were already set to “low” so as not to effect other devices on my network.

I have restarted both the Nucleus and MacBook and still looking good - no server connections interrupted. I also brought back online my 2 Synology NAS drives and 2 other routers - still looking good.

One other thing I changed after the DNS change was to remove the reference to a shared Music folder on one of the NAS drives. Although the drive was marked “disabled” on the Nucleus settings I completely removed it.

So that’s were I stand - everything is looking good. I appreciate all the feedback and ideas from the group. Everyones input was consequential - thank you!

3 Likes

Hi Stephan,

Can I marked this solved then?

Yes, unless anyone had any follow-up questions for me?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.