Set headroom only for upsampled audio

Hi there

Hope you are keeping well. I enjoy upsampling the CD quality audio to HiRes. The only problem is that usually upsampled audio causes clipping. Even when PEQ is off. I tried upsampling with a linear phase filter and with smooth filters but clipping always occur at least sometimes when the audio is upsampled.

I don’t like to put headroom adjustment for HiRes audio. How to avoid manually change the settings and set Roon to automatically set a headroom only for upsampled audio and to avoid headroom adjustment for HiRes audio ie not upsampled audio. I mean without changing manually the settings.

I see there is an option to automatically adjust gain when DSD is converted to PCM. It will be useful to have the same option with adjustable negative gain for PCM only when upsampling options are running.

Any help will be greatly appreciated