Set Volume limits ignored with Hidizs S9 Pro @ MacBook Air M1

Roon Core Machine

Intel NUC with latest ROCK.

Networking Gear & Setup Details

Netgear Orbi WiFi

Connected Audio Devices

Hidizs S9 Pro
connected via USB C to
MacBook Air (M1, 2020)
running MacOS Monterey 12.0.1

Number of Tracks in Library

0 - just using Qobuz or Live Radio

Description of Issue

I’m using the DAC as output device in exclusive mode with volume control “device volume” and trying to set the volume limits because otherwise my ears and my Hifiman Ananda are blown up.

This works perfect in current lifecycle, but the values look like to be not persistent after reboot or plug-out/plug-in of DAC. It looks like the same behaviour as in →

Hey @Matthias_K

Thank you for reaching out to us with your question. I apologize for the delay in responding. I had hoped to get back to you sooner and appreciate your patience.

I am very sorry to hear that you were having issues with your DAC recognizing the volume limits you’ve set. Since there’s been a delay in getting back to you I wanted to inquire whether you were still having this issue or if the behavior has changed on our most recent builds.

If you could please send us an update about your status that would be great. I’ll be watching for your message and get back in touch as soon as I can.

still an issue, maybe even more weird. Sometimes when I disconnect/reconnect the DAC or reboot the Mac and I restart directly the stream by pressing “play” the loudness itself is ok, even if the GUI shows 100. If I then click into the volume slider it’s “100-Loud” again. And sometimes it start with 100 in GUI and also the loudness is on this level. maybe a sign that loudness level is not send to GUI?
Hint: I also run a volume limit set to 70 (but this also does not to work with loudness gets set to 100 by the system somehow).

…and now some other disconnect/reconnect and it’s working. Sorry I can’t see a pattern. Honestly: I rarely use my notebook as a roon endpoint, it was more or less just the enablement. If it’s just me…

We’d be happy to take a closer look if you’d like.

Can you repeat the steps that you typically use when the Roon/Hidizs S9 Pro behaves this way and note your local time when this happens then drop the date/timestamp details here in the thread?

We’ll pull diagnostics from our side and take a look.

I think I found it. Volume keeps persistent without sample rate conversion. But if I use the DSP function sample rate conversion it shows the strange behaviour I reported. Tests were done a few minutes ago (so about 9:28) and I will repeat disconnecting/reconnecting right now for some more times for your logs from 9:30.

Prereq.: DSP - sample rate conversion = ON
1.) play music
2.) set volume to e.g. 25
3.) still playing
4.) disconnect
5.) reconnect
6.) play
7.) GUI always loudness 100
8.) sometimes loudness still low / sometimes at 100 (even if max level is set to 70)

7 posts were split to a new topic: Volume Limits Overridden on start up to Hiby R5 DAP and Ropieee

Hello again @Matthias_K

I have some additional input to share from our Hardware Expert. This doesn’t appear to be a Roon problem, I’ll address why in a moment. What you’re experiencing is likely due to how UAC2 volume implementation is being handled on. the device itself.

A. Roon is does not change the volume of the device unless the user explicitly uses the volume slider or buttons.

B. The Roon volume limit prevents the Roon controls from setting the volume over a certain value, but it cannot prevent the device from changing its own volume.

C. You may be able to avoid this by using DSP volume instead of device volume. See last paragraph in this article and please give this a try:

works with “DSP volume” - not perfect but a workaround. Thank you!

1 Like

Hi @Matthias_K,

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.