Setting metadata for all albums

is there a way to tell roon to prefer “file” for ALL album titles?

Yes. If you mean all your local files. (Settings > Library > Import Settings. Set the metadata preference for the Album Title to “Prefer File”)

No, if you mean albums in your library that come from a streaming service (Tidal and/or Qobuz). These don’t exist as local files.

thanks geoff. i’m not sure how long it will take roon to recompute metadata after making this change (~10,000 albums are involved). should i expect to have to restart roon? the computer? to see the changed album titles?

You shouldn’t have to restart Roon, but for 10,000 albums(!) it will take some time, as the warning on that settings page states…

thanks again - yes, the fan on my mac mini is spinning like mad - i expect to see it take off and fly out the window.

(btw: over the years i’ve gone to some trouble in itunes to retitle the albums (nearly all classical) to show composer’s last name followed by “:” followed by work, e.g. <Beethoven: Symphonies #7 & 3>. it would have been painful to lose this sort order.

I’d be curious to know how you find the experience in Roon once the database reshuffling is complete, and you’ve had a chance to kick the tyres, so to speak. Personally, knowing that Roon is “opinionated software”, I wonder whether its opinions on how albums should be organised will clash with yours.

my first impression is that the UI is too busy. i can’t seem to find a way to alter the size of the album covers. i’d prefer to see more covers at a much reduced size.

i should explain my reasons for moving to roon (or testing whether i should). i had to update my mac os in order for itunes to recognize my new dac (the schiit yggdrasil). but itunes no longer supports gapless playback, which is Death to Opera. needless to say, “gapless” was set manually on every album in my collection. it’s too early to say whether roon will respect that setting, or produce dropouts between tracks.

otherwise, so far so good. if i can substitute my opinions (which are, obviously, superior to roon’s in every way :slight_smile: ) for roon’s, i’ll be a happy puppy.

Settings > General > “Allow for more covers and photos?” - set to “Yes”

BTW, Roon plays gapless by default.



1 Like

BTW, if this is a new installation of Roon, then the first thing it will attempt to do is Analyze your local files.

With 10,000 albums this is going to take some time. Depending on the capability of your Mac Mini, this could interfere with playback, as the analysis is compute-intensive. Some people prefer to get the analysis over and done with quickly (see the KB page for details) before listening to albums. However, with the size of your collection, you could be twiddling your thumbs for quite some time. Hopefully, the default Throttled setting will be sufficient to allow uninterrupted playback.

thanks - one further problem i’ve noticed is that after playing the selected album, roon goes on to play a second. is there a setting which will turn this behavior off?

That’s the “Roon Radio” feature. It’s turned on by default. You can turn it off on the Queue screen - see here.

You haven’t stated your Mac mini model year etc and ~10,000 albums is a lot of tracks to deal with…if it’s an older macmini like Pre 2014 then be prepared to wait a good week or so at least I’m guessing if it needs to analyze the tracks.

thanks - it took about five minutes, or less.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.