Setting up ARC (possible CGNAT)

So how game streaming from Microsoft Xbox console to mobile Xbox app works? Yes, I’ve got private dynamic IP and my ISP has got public IP. This is not an obstacle for finding Xbox console, but for Roon it is.

These don’t work with CGNAT. You appear to have a unique IP address that isn’t shared with other ISP customers; Roon ARC works okay in that scenario.

If you wish to continue this discussion–the support request is now resolved–please reply as a linked topic. Thanks.

Screenshot from 2022-09-21 22-38-53

So, is it some way to resolve problem with multiple NAT without giving me public IP by my provider? It will me cost extra money, besides, I want to avoid that for security reasons.

@Slawomir_Kubicz, I have moved your posts to a new thread, so they get appropriate attention.

It would be really helpful if you completed the support template below, and provided details of your ISP, the modem / router make and model, and any other network equipment you are using.

Roon Core Machine

<!-- Include your operating system and machine info (Model, CPU, RAM) -‐>
<!-- Write below this line -‐>

Networking Gear & Setup Details

<!-- Your network gear (model of routers/switches) and if on WiFi/Ethernet, are you using YPN -‐>
<!-- Write below this line -‐>

Connected Audio Devices

<!-- Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.) -‐>
<!-- Write below this line -‐>

Number of Tracks in Library

<!-- Tell us how large your music library is, eg. “30,000 tracks” -‐>
<!-- Write below this line -‐>

Description of Issue

<!-- Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated! -‐>
<!-- Write below this line -‐>

1 Like

Roon Core Machine
Dell Optiplex 9020 Intel Core i5-4590S, 8GB RAM, 256GB SSD Drive, Windows 10

Networking Gear & Setup Details
Fiber, Dasan GPON ONT H665 Unit, TP-Link AX5400 Archer AX72, TP-Link switch TL-SG1008D, if You mean using VPN, then no.

Connected Audio Devices (not at the same time)
Onkyo TX-8270, Oppo UDP203, Raspberry Pi4 with ropieeeXL–>SMSL m500.

Number of Tracks in Library: 24799.

Issue - multiple NAT

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 193.243.155.71:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“193.243.xxx.xx”,“router_external_ip”:“192.168.10.102”},
“status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.0.1”,“found_upnp”:true}
}

Add images

Since you have two routers, you have multiple NAT, so Roon can’t configure your network to allow access to your core.

Please see this guide, especially the section “Multiple NAT”.

I don’t have got two routers. But my router’s IP is dynamic internal/private IP (192.168.0.1). IP 193.234.xxx.xx is public IP on my provider’s side. I don’t have got any access to it. What I should to do to get public IP from my provider but I don’t want to do it for security reasons.

Second TP-Link unit I mentioned it’s a switch.


I found this option in router’s advanced settings. I wonder what will happen if I uncheck NAT option.

You have the Dasan H665 for FTTH (Fibre to the Home), which works as a simple Bridge or behaves as Router/NAT. Since you have the TP-Link AX5400 Archer AX72, too, it would seem that it is the latter, i.e., you have double-NAT.

Ok, I get it. So, can I disable NAT in Archer? What will happen after I do it? I read one’s thread in other forum, he disabled NAT in Belkin router and lost access to router settings (couldn’t find router’s IP or something like that).

An ONT doesn’t or shouldn’t do any NAT’ing (I’ve never seen one that does)

So, {“actual_external_ip”:“193.243.xxx.xx”} is my provider’s public IP and {“router_external_ip”:“192.168.10.102”} is my private/internal dynamic IP. I think that in the first place.

Can you access the Dasan web interface? Or is this on a different subnet?

I don’t have access to Dasan. My provider does.