Setting Up Roon + HQPplayer + MicroRendu

Hello!

I’ve recently downloaded HQPlayer Desktop 4.5 hoping to add the software’s DSP capabilities to my Roon ecosystem. Unfortunately, its is not working. HQP does not see the mRendu. The latter is visible and accessible through Roon however. Roon Core and HQP are on the same NUC10 7 PC. HQP was set up as a zone in Roon using ‘localhost’ option. The plan was have Roon stream to HQP and through LAN connection (using NetworkAudioAdapter Protocol to the microRendu and finally through a USB connection to a SMSL 500 dac.

In HQP’s Settings, Input Backend is set to NetworkAudioAdapter but can’t find mRendu to set as Device, As for the Output, Backend is set to Asio and Device to the SMSL Dac. I also change the protocol from Roon to NAA for mRendu.

I’ve tried rebooting every component (many times in different order) in the chain and changing the IP address of the mRendu to a static one but HQP has not picked up the network adapter.

As anyone encountered the problem when setting up HQP and been able to get everything working ?

Thanks!

I take it you sucessfully reset the mR to NAA.

What do you want to use as input through microRendu? Do you have some input device connected to it?

In first paragraph you say you want to use SMSL DAC, and in second you say you have the output set to ASIO and SMSL. So what would be the input behind NAA?

Yes, I made the switch from Roon Ready to NAA.

Yes, made the switch from Roon Ready to NAA.

Sorry for the confusion. To clarify, both Roon Core and HQP réside on the same PC. The PC is itself connected to the microREndu by wired LAN. The mR is connected with USB to the DAC.

In the Settings Menu, I set Backend/Device for the Output at Asio/USB Audio For the DAC. For the Input, Backend/Device to NetworkAudioADapter/No Option are shown.

Input Backend should be none. output backend should point to the naa.

Likely reason is that you don’t have input devices connected to the Rendu.

If you want to output through Rendu to your DAC, you need to set output backend to NetworkAudio and select the DAC behind Rendu. If there are no DACs connected (and powered up) to the Rendu at the point when you select the NetworkAudio backend, they won’t naturally show up.

If you want to input through Rendu, you need to have suitable input device connected to the Rendu, such as ADC or digital input device. If there are not input devices connected, there’s nothing to show even if Rendu itself is alive…

1 Like

Thank you :pray: ! I will give a try later tonight when I get a chance.

1 Like

Thank you. It does the trick!

1 Like