Setting up the Bios in a NUC7i7BNH

According to the ROCK setup directions, you must update the Bios to the latest version, which I have done. Next you must select the legacy method, which I have done. However under that it reads “no boot disk”, so evidently it cannot see my ssd. What now?

Have you already installed ROCK onto the SSD from your USB stick? If not, then I think you should do that first - a blank SSD does not have a boot partition on it… In other words, I think that message is to be expected.

Hi Geoff,
So your saying I need to install ROCK on the SSD first and then reconfigure the BIOS? I’m kind of a Rookie here. I’ll give it a try.

Installed Etcher on my windows 10 computer, tried to run it and get my Roon software boot image to work, and it wouldn’t let me flash the gz file on my USB stick.

The gz file is a compressed file. You need to decompress it first to get the image file that Etcher needs.

I think the instructions on the KB page are not clear…

I cannot get the gz file to work, trying decompress using Express Zip software, tried doing it on my MAC. not letting me do it for some reason.

Use The Unarchiver on Mac and you’re all set.

Etcher can burn the gz file directly… It takes care of uncompressing


Ah - OK, thanks for that piece of enlightenment. John seemed to be saying that Etcher couldn’t deal with the gz format file… So I put two and two together and made forty-six.

Don’t feel bad: I tipped @danny on Etcher a while ago. How quickly one forgets… :wink:

I got it to work, In fact my iPhone can see ROCK. Do I need to play with codecs? Computer for dummies here.

ROCK Rocks, through my Sonica DAC. How do I enable DSP, since I was doing it from my Windows 10 core before. Also, removing TIDAL duplicates of my library albums. Thanks for the help today.

Honestly, when I did mine last week, the below from CA was the most helpful:

Thank you!