Settings not displaying properly or crashing [Resolved with Build 756]

Same experience after reboot the problem came back

bad… nothing works. uninstall roonserver and remote-app and install again, again no chance to get to settings.
and i don´t understand the fully roon: there i can open setting but no more backups possible?
at the moment, i can´t listen music… really bad

thanks michel, but didn´t help.

Hi @dylan only set the “Regionales Format” to English (USA) and it works with any language roon-settings

1 Like

Crash on iPad and iPhone when scrolling fast through playlists and when choosing preferences.

1 Like

Hello @El_Manu ,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Are you referring to a crash when trying to access Roon Settings , or what preferences exactly?

How many items are in the playlist that show the crash behavior?

Hello @noris,

thank you very much.

The Rock Intel NUC8i7BEH2 is connected wired to a HP 8 port switch which is connected to a fritz!box 6490. No connection issues at any time.

  1. question: It crashes on iPad, when clicking “Einstellungen” Settings and the tab was not changed to system language “English”. Directly when accessing it.

  2. This playlist (which is stable since changed to English iPad system Language) has 70 tracks (5 hours) of music.
    Another advice I can give: When scrolling in German language of iPad, there were nice purple round shapes after the tracks. These are gone since Tab Language change to English … so these “nice” round cirkles or ellipses or so what were an error, I think.

Hope I can help solving the bug.

Here the visual effect:

Best regards

1 Like

Thanks Leon for the work-around. Both languages settings are Dutch is my case. I will see what I will do. Depends also how long it Roon takes to fix this bug.

Ich kann kein English.
Wann wird das gefixt?

It is absolutely tied to the Regional format of the Windows 10 PC I’m using (OS: 19042.746 / 20H2)
using English menus etc. I even tried with different keyboard languages (English and Danish). So after some experimenting I could conclude that the following regional settings didn’t work:


But it only worked when I changed Regional format to English (United States or United Kingdom)

BUT that really ruins all the formats and decimal separators :frowning:

SO the work around is to select the English Regional format when using the Roon Settings, and then change it back after you are done.

BR Jan

It’s a crap.

After automatic refresh to 1.8 the Roon never working in Win10 Pro 64 bit HU:

02/10 18:00:46 Warn: System.FormatException: Nem megfelelő a bemeneti karakterlánc formátuma.
a következő helyen: System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
a következő helyen: System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
a következő helyen: Sooloos.Version.Deserialize(String str)

All, here are screen shots after moving to 1.8 on my MacBook Pro and iPad Pro. Over a week prior I was unable to even use 1.7, which will be a conversation with Roon with respect to clawing that back to my subscription.


I switched to english settings … the application again did not start.
Downloaded manually the Roon software and install it.
Now working … more or less … no Tidal login (from web app its working).

The playback SQ is unclassifiable, significant setback from previous version.

How can I reinstall 1.7?
How can i disable the automatic update on ROCK core and Roon application?

1 Like

I have tried different language settings on my laptop (W10, German). It is sufficient if only the time format is set to English US. The settings work.
I had changed the time format directly via the old control panel (short: timedate.cpl).
Initially, the “Regional Format” remained on “Germany”; after a reboot it was also set to “English US”.
So I can confirm that the decisive setting is “Regional Format: English (United States)”.

Oltre ai problemi di sull’ IOS di iPad, perché le informazioni sugli artisti non si visualizzano con la lingua impostata all’inizio?
sono italiano perché devo leggere in inglese, il canone lo pago anche io

for me, now the only question is, how fast Roon will fix these problems. it is a shame…

Client Machine (windows 10 20H2/Intel® Core™ i7-10510U CPU @ 1.80GHz 2.30 GHz/Roon build number 1.8 )

After update 1.8 I have on my windows client problems with the Roon gui. in specific not being able to go to the settings menu, strange purple artifacts here and there (and I hate purple already)
I have added some screenshots.
overall I am happy with the 1.8 update, except for the design look and feel (too many fonts used/ mixed sizing, awful color scheme) and buggyness of windows and android client.
So please fix these issues pronto,… looks like a very cheapo release.

PS functionality is really good and elaborate, nicely done…


HI, I have the same problem. The only Settings screen I see is the General settings. Where are the AUDIO and Storage locations in the Settings? Also, the screen looks ‘crippled’ on the position where I can set the language. The problem is in Italian also in English.

worked for me, changed it to UK English and all strange behaviour disappeared.

Hi everyone!

We’ve just release an update that we believe will help here. Please give this update a try and let us know if things are back to normal!

Thanks for your patience as we’ve worked to get this fixed.