Settings not displaying properly or crashing [Resolved with Build 756]

Client Machine (windows 10 20H2/Intel® Core™ i7-10510U CPU @ 1.80GHz 2.30 GHz/Roon build number 1.8 )

After update 1.8 I have on my windows client problems with the Roon gui. in specific not being able to go to the settings menu, strange purple artifacts here and there (and I hate purple already)
I have added some screenshots.
overall I am happy with the 1.8 update, except for the design look and feel (too many fonts used/ mixed sizing, awful color scheme) and buggyness of windows and android client.
So please fix these issues pronto,… looks like a very cheapo release.

PS functionality is really good and elaborate, nicely done…


HI, I have the same problem. The only Settings screen I see is the General settings. Where are the AUDIO and Storage locations in the Settings? Also, the screen looks ‘crippled’ on the position where I can set the language. The problem is in Italian also in English.

worked for me, changed it to UK English and all strange behaviour disappeared.

Hi everyone!

We’ve just release an update that we believe will help here. Please give this update a try and let us know if things are back to normal!

Thanks for your patience as we’ve worked to get this fixed.


I had the same problem yesterday.
I use 10gen NUC, and usually no need to turn off HT above 7gen CPU, but I seem to turn it off
After I restarted HT, the loading speed of other information was guaranteed.

This makes me think that Roon 1.8 needs more CPU multi-core computing, after all, it will load more data.

A post was split to a new topic: Can’t save edits on Windows device

A post was merged into an existing topic: Can’t save edits on Windows device

2 posts were split to a new topic: Settings still not working after update

‘settings display works now, using German as system language. Save the Edits not working,
But the sound is still high end.

Working fine!

One ‘problem’: the downloadable Roon version on your website is still the old one.

1 Like

Hard to judge from these screenshots, but when I saw my save button greyed out like yours, it meant the cursor had moved to an empty field (not one I expected, so a bit odd behaviour) and was waiting for input.

Deselecting that field made the save button appear again.

However I agree with that the save button should not swap places between remotes.

You are correct :slight_smile:
A mouse click away from the date fields after the last tab/entry makes the save button reappear now. I can work with that …

Thanks for the quick update!
Everything works ow fine here [The Netherlands].

1 Like

i have been using roon since october2020
and with the new version 1.8
i got the mentioned problem with settings
on my roon core , a lenovo i5/1.8ghz quad
16gb ram a normal pc but used as core
(settings was only displaying the general
and also a problem with my iphone8
where accessing about and display
under settings caused a crash.

I changed the display langauge i windows10pro os from danish to english us
and on the iphone8 the ios14.4 langauge
to english probably us english or uk english
an the problems dissapeared all was working

then the update came (build 756)
and i installed it on my roon core
and changed the langauge in windows os
back to danish and changed the ios langauge
on my iphone8 back to danish
and restarted both machines and it was fine
with the core running (build 756)
no probems on the core
but the iphone8 running remote (build748) now in ios danish gained the problem that it chrashed when about or display was pressed under settings

now the great part.
i updated the iphone8 remote to (build 756)
and now all was good , no more problems
settings was displayed normaly without any
and both my core and remote are set to danish langage as the os and ios langauge and the langauge for roon itself set to english

my system is running good
and i think the new version i fine
but with all new things it takes time to get
to grips with and get to know well

i think roon is great.

on a closing note : i only run tidal hifi
and a few web radio stations on the system
so none of my own collection of cd’s.

have a good day

I’ve downloaded a new update this morning for 1.8 for my core and windows and the menu settings are now fully available. Well done Roon! Thanks!
The only thing I’m still trying to figure out is the Discovery function - isn’t there supposed to be a shortcut in the menu?

Go to the Home page, and scroll down the page until you see the Discover panel. The panel is clickable - so click on it to open the Discover page.

Thanks. Yeah, I am seeing “Discovery” after scrolling down but I’m referring to a direct access on the menu on the left. Wasn’t this there before with 1.7?

Yes, it’s been demoted apparently :slightly_smiling_face:

that explains problems for some. my version was not promted for “self upgrade”, I had to do manual - but as you said, downloadable version is still initial 1.8 version - with the bug

Hi Dylan tried that tip. With my iphone 12pro and various ipad Gens, it didn’t work to switch from German to English Language