Setup Advice: Nuc+ > SONORE ultraDigital > Crestron Amp

Greetings. I am new to the forum. Been using Roon for a while now, but am taking some time to validate that my setup and configurations are optimized. I used 6 endpoints in my system, so - unless I find specific answers elsewhere on the forum - I will probably create topics for each endpoint.

Today, I am focused on the endpoint we use for distributed audio around the house. We have a Crestron SWAMP DSP amplifier (along with 2 SWAMPE ‘extension’ amplifiers) powering “architectural” speakers (ceiling, outdoor, etc.) around the house.

This amp has built-in DSP and also sends digital audio signal (via ethernet) to the ‘extension’ amps around the building. Clearly, it is not “Hi Fi.” Given this digital architecture, I saw no reason to use an upstream, external DAC to feed it an analog signal since it would be converted back to digital (ADC) and then back to analog (DAC) within the amp.

Conversion specs on the SWAMP amplifier:

  • Analog-To-Digital Conversion 24-bit 48 kHz
  • Digital-To-Analog Conversion 24-bit 48 kHz

SO, I am feeding it digital audio from my Nucleus+. Signal path:

My questions today are about optimizing setup and config within Roon.

1. Which endpoint to use?
Interestingly, in Roon Settings > Audio > Connected to Core, I see two options:

The Nucleus HDMI Output is just that. The “0.0 House Roon” is the SONORE ultraDigital. Obviously, I am using the SONORE for now. I guess question #1 is which of these should I enable and use?

2. If I stick with the SONORE as endpoint, how to optimize setup?

Here is the setup screen. NOTE: Clicking “Identify this device” is not helpful. It does not identify.

These setup options really get into the meat of the coconut. A lot of this is cryptic to me.

Any feedback or guidance would be appreciated.


When you click identify this device, it should then present you with a list of manufacturers.
You should be able to choose the box for Sonore and then pick out your unit.
Roon does not automatically detect every device attached, you sometimes have to " help" Roon.

Thanks Kevin. I actually tried this and ultraDigital is not listed in the options. I suppose I could select ultraRendu and see what happens?

I have done similar myself when I have found my exact device was not listed.
It gave it a nice picture and did not seem to have any adverse effect on anything else.

Jesus R. from Sonore support says selecting ultraRendu is fine.

Since my downstream DAC is limited to the specs below, should I set “Max Sample Rate (PCM)” and “Max bits per sample (PCM)” on this Sonore device to match at 24-bit 48kHz?

1 Like

I think that would be the best move.
If you inadvertently played say a Qobuz hires file at 24/96 your amp would not be able to handle it and the sounds you would hear( if any) would be most unpleasant.
So yes set in the Roon setup to match at 24/48 and you should be good.

What about the two MQA settings? Any guidance on how to handle that?

Just turn both off.
I see the first one is set to no mqa support which is good.
Second one move the slider so it says no.

I fear even if you had Tidal and ran mqa with the amp limited to 24/48 you might not see any benefits.