SGM unable to connect to Roon after recent update (ref#ID9OHC)

Is Roon Server running?

· No, Roon Server is not running.

For Roon connectivity to work properly, both Roon Server and Roon Remote need to be turned on.

· Roon Server is on, but I'm still having trouble connecting.

What do you see on your screen?

· "Looking for your Roon Server"

Please try to restart your Roon Server by closing the Roon app in the taskbar or rebooting your Roon Server machine.

· No, the issue remains the same

Please try to restart your network setup by unplugging, waiting 30 seconds and then replugging in your networking gear.

· No, the issue remains the same

Please select how you've connected your Roon Server to the internet

· Roon Server is connected by *Ethernet*

Have you checked your firewall settings to ensure that Roon is allowed through?

· Roon still won't connect even after checking this aspect

Have you verified that Roon Server is on the same subnet as your Remotes?

· My Remotes and Server are on the same subnet and I still can't connect

Sometimes the issues can be resolved with a reinstall of your Roon Remote app. Let's try to perform a reinstall and see if it helps.

· I've reinstalled the Roon Remote but it did not help

What is the operating system of your Roon Server host machine?

· *Windows*

Select any of the following components that are present in your local network setup

· *Mesh networks*

You mentioned a mesh network in your setup. Certain common mesh networks might require slight reconfiguration to support Roon.

· None of the above

Describe the issue

roon won't connect to my SGM for months now after a roon update

Describe your network setup

netgear router hard wired via ethernet

Hi @Steve_Ferro,

The SGM isn’t visible to our account diagnostics.

  1. Does this device have an IP address on your local network? Is it on the same subnet as your other machines?

  2. Do you have any firewalls active on this network that might be actively filtering out the upstream connection to our servers?

  3. Please try a full database reset (if you have a recent and reliable Backup available):

  • Exit out of RoonServer
  • Navigate to your RoonServer’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall the RoonServer App from our Downloads Page to generate a new RoonServer folder
  • On the Roon Remotes, press “Use another Roon Server” and connect to the new database

Hi
Thank you for getting back to me.
I assume the SGM needs to be on for you to see it, I have shut it down because I don’t see the point of leaving something on that doesn’t work.
I admittedly am not great with computers so the likelihood of me being able to do any of what you described is unlikely. So unfortunately I’m not sure how I’m going to be able to fix this. Is there a simpler way or maybe a more basic way of describing what it is I’m looking for and trying to do? I always knew this day was coming, The day when my music doesn’t work and I have no clue on how to fix it, It’s probably better honestly if I just spin CDs, but I really like the large library access.
Any further help you that offer would be greatly appreciated. I would just like to get my music back
Thank you
Steve

Hi @Steve_Ferro,

Thank you for your patience in awaiting a response.

The follow-up steps are actually quite simple - first, just try turning on the problem RoonServer machine (the SGM). We’ll learn a lot from that alone without your intervention,

Do you have any new antivirus software or firewalls that you’ve installed in the last few months?

Hi Connor.
Thank you for getting back to me regarding my issue. I turned my SGM on this evening. How is it that you can see my server? I’m just interested in knowing and understanding. Also, I see roon came out with a new titan server, If I were to get one of those to replace my sgm would I be able to transfer my lifetime subscription to roon to that? Also, any idea how the sound quality might compare between your Titan and my sgm? Because honestly the SGM when it worked was pretty amazing.
Thank you again for your help!
Steve

Hi @Steve_Ferro,

Thank you for your gracious display of patience awaiting a response here. Is your SGM on the same WiFi/ethernet network as your Roon Remote? We’re still not registering the device on our end, so we want to make sure antivirus software or a network firewall isn’t interfering.

RoonServer pings our account servers to authenticate a session. When we activate diagnostic mode for your account, we can see a timestamp of the last successful authentication.

Absolutely. You can migrate your RoonServer as many times as necessary to keep your hardware current. A RoonServer instance on a partner machine like an SGM hits all the benchmarks for performance that our team tests for - it’s no doubt a competent and powerful setup. That said, the Titan scores higher for CPU benchmark on a single core, maximum memory bandwidth, and RAM speed than even previous Roon Nucleus models. You’ll find it to be beyond well-equipped to perform the role. We’d be happy to answer any specific questions.

Hi Connor.
Thank you for your reply.
Yes, the SGM server is on the same network via Ethernet as the roon PC. I checked the antivirus software and don’t see a conflict there at least with my limited computer abilities.
When this happened meaning the loss of communication between the sgm and roon. I didn’t change anything. No hardware. Just an update was performed. I believe it’s been so long actually since I’ve had music that it’s hard to remember what actually caused it or when it started, but I believe an update was done and that’s when the music stopped.
I’m not really sure how to remedy this. I’m sincerely hoping that you guys can figure it out. If not, I’m not sure what to do.
Thank you again for all your help.

Good afternoon @support,
Is there any chance I can get further assistance regarding my Roon not seeing my SGM after an update?