Shuffle playback of tagged tracks - some tagged tracks trigger play of the whole album?

Roon Core Machine

Grimm Audio MU1 - firmware 1.4.4
Roon version 2.0 (build 1128) production

Networking Gear & Setup Details

TP-Link AX6000 WiFi router → TP-Link TL-WA1201 access point → Grimm Audio MU1 (CAT6 ethernet cable)

Connected Audio Devices

Holo Audio May KTE DAC (connected to MU1 via AES3 interconnect)

Number of Tracks in Library

~8,000 tracks; 550 albums

Description of Issue

I have a set of tracks (about 240) from my library tagged as “Reference”.
When I play back such Reference tracks, in shuffle mode, some of the tracks trigged a playback of the whole underlying album, and not only those tagged as Reference?

For example here is a screen shot of some of the tracks tagged as Reference. You can see that two tracks are tagged from the Hamilton album.

And here is a screen shot of the shuffled queue from these Reference tracks. You can see that all 46 tracks (“46 parts”) of the album Hamilton are brought in the shuffled queue for playback, and not only the two tracks tagged as Reference?

What is strange is that this does not happen with all tracks from all albums. Only a few, like the Hamilton album provided as an example. I will add that I had not experienced this behavior on 1.8.

Thank you in advance for your support.


A lot of Classical music is organised as muti-part compositions. For example, a symphony will usually have several movements and roon will generally treat the entire composition of 3 or 4 tracks as a single unit for play-back purposes. Other genres also follow Classical multi-part composition grouping conventions as with your Hamilton musical example.

On a case by case basis if you would prefer roon to treat an album as collections of single tracks rather than groups of multi-part compositions you can switch this behaviour on/off:

three dots → edit → edit album

You then need to scroll right down to the bottom (difficult to do as there are no scroll bars).

I don’t know if there is a global switch to prohibit roon grouping compositions.

1 Like


Thank you for your help on this, which I appreciate very much. I did check your point, and the Hamilton album indeed has the Multi-Part Composition Grouping selected.

However, I also checked another album, Tutto Pavarotti, from which I also have a few tracks selected as part of my Reference tag, and while the Multi-Part Composition Grouping is also selected, the shuffle playback of those tracks do no bring the whole album into the playback.

I do note however that under the Multi-Part Composition Grouping, the Hamilton album says “46 tracks, 1 recording”, and the Tutto Pavarotti album says “31 tracks, 31 recordings”, which may be the source of the behavior.

I don’t know however, and will wait for further advisement from Roon Support and others.


Rather than shuffling from tags could you create a playlist of the tagged tracks and shuffle the playlist instead?


Thank you. I have never used playlists in Roon. I have only used tags thus far.

Based on your suggestion, I created a small playlist, with 6 tracks, including the two tracks from the Hamilton album I referenced in my original post. I played it “shuffle”, and interestingly, while those two tracks in such playlist do not bring the rest of the album into the playlist, they play together as two parts, and not fully shuffled…

The plot thickens… Another bizarre behavior it seems for the Roon Support teamto chime in.


1 Like

Did you disable multi-part grouping on the Hamilton album to get the behaviour you prefer? Until you do that roon will continue to group the tracks as part of a composition in all sorts of functionality scenarios. BTW, roon is not playing the entire album, it is playing the entire composition. It is just a coincidence that there is a single composition on that album so it looks as if the entire album is being played.

In your Pavarotti example roon has made 31 multi-part compositions that each have a single track. I doubt that was planned either by roon or their metadata supplier. It makes no sense and is just an outcome of poor meta-data that by a coincidence gives the behaviour you prefer. You could disable multi-part grouping for that album as well and it will also give the behaviour you prefer.


Thank you much for your wisdom and help on this.

This aftertoon I disabled multi-part grouping on the Hamilton album as you suggested, played my Reference tag shuffled, and only the tagged tracks were brought into the playback (which would be my expected “correct” behaviour).

I still do no understand why such multi-part grouping would trigger such a behavior since I only have two tracks from the Hamilton album tagged as Reference.

For information, the Hamilton album is one I “subscribe to” from Qobuz, so I assume the metadata comes from them (but I am not sure as Roon may have their our library).

The Pavarotti album on the other end is one of my own which I ripped through Apple iTunes / Music, so I assume the metadata come from them or whatever service they use (but again I am not sure as Roon may have their our library).

So while this provide a solution to my issue, It is still a mystery to me as to the fundamental reason for the issue.


I don’t think there is really a mystery. Roon’s default handling of multi-part compositions is Classical focused where it is the normal way to organise the vast majority of that genres music. For those with Classical libraries this behaviour is “correct”. You just need to switch that behaviour off if you don’t like it. It sounds like you would prefer to switch that behaviour off globally rather than on an album by album basis. I don’t know if that is possible.

Multi-part grouping crops up as a requirement in other genres as well, but much more infrequently. Meta-data, though, is of very variable quality and mistakes and gaps from roon’s sources are common especially with compilations, box sets, and various artist albums. My guess is that in the case of your Pavarotti compilation, many of those tracks are arias taken from multi-part operas, and the multi-part tags were taken over from the source albums when the compilation was made.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.