Shuffle stops working and Roon simply plays an album in order

Core Machine (Operating system/System info/Roon build number)
ROCK running on a NUC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Naim Uniti

Description Of Issue
Whilst listening on shuffle (on this occasion all albums) the music was playing fine and shuffle was working … but then after about 30mins the shuffle stopped and the music simply came from one album.

This has happened before but I ignored it as I wondered if I had pressed something. But now it’s happened for a second time I wonder if it’s a bug.

Was that a classical album, I’m wondering if it was just a long composition (Roon plays these as a whole).

It was a classical album which it started playing after having been on shuffle but the album is split into different tracts (rather than one long single track) and the album is split into two different pieces of (music two different composers) so it’s not a single piece on the album.

I would look to see if the album it happened on previously is designated as ‘classical’ but currently the iOS app crashes so frequently that I can’t even navigate to the library without it crashing on my phone. Sigh. Very frustrating.

Hi Carl, you’re right! Perhaps you knew that already! When there is a classical piece, it groups them into parts and then plays the whole set of parts before continuing with the shuffle.
When a symphony lasts 1.5hours this is quite a shift. Do you know if there’s a way to disable this feature - the reason I ask is that sometimes I use shuffle to work out what music I’d like to listen to… if it gets stuck on a piece of classical music it’s doing something different from what I was expecting.

I suspect as such.

It can’t be disabled, however, try focusing by exclude classical, before shuffling.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.