Shuffle turning on randomly

Core Machine

Windows 10 laptop

Network Details

Core is ethernet to BT router, remotes are all WFi

Audio Devices

Naim Uniti Atom

Description of Issue

Shuffle randomly turns on, especially when I fire up Roon on either my Macbook or iPad. Am I doing this accidentally somehow? Is this a known fault with the software? I wish there was an option to disable shuffle and repeat, I don’t need them…

Hi Jon you will find a few of these posts here, and they almost all end with the user’s (myself included) concluding that we have turned it on by accident, as it is quite easy to do.
If you look at where the icon is then you will see it is quite easy to hit by mistake

Hi Michael, many thanks for your response but I don’t see how I’m doing this. The icon, unless I’m missing something is top right in the queue window and when you’re using a laptop you’d surely have to be quite precise to click it?
Or am I missing something and it’s somewhere else as well, or a keyboard/trackpad shortcut that I’m performing accidentally? Sorry if this has been posted before - I have Googled and not found similar threads

Hi Jon the threads are on this forum, I have seen a couple of the last few years.

Unfortunately I am on holiday at the moment and away from Roon so I can’t look, it turned out for me that I was doing it on the pc and not mobile, but I did work out eventually what I had done. Though I have not seen any of these discussions since 1.8 was released.

It’s just happened again - I picked up my mobile, hit play in Roon and then glanced at my stereo to see something further down my queue playing - sure enough it’s gone into random mode. There isn’t even a button for that on the active view on the phone. It seems to happen when I first pick up a device and play Roon at the start of a listening session.

Hi Jon what phone are you using.
I see there is a button at the top of the queue manager, have you been in there at all?

Hi Michael, nope, not been in there at all. Don’t know why this is happening…this happened when I hit play whilst on the home screen. This was on a OnePlus6 phone, but it’s happened when I’ve used my iPad and I’m pretty sure my MacBook as well…

Jon good taste in phones, as a long term OnePlus user as well, I started with the OnePlus One and currently on the 9 Pro.

I don’t really see anywhere else on Android to change this on the current version and the iPad app (it was easier on the old versions)

See the screenshot below.

So, this evening I’ve just fired up Roon for the first time in 24 hours or so. That is to say, it runs permanently on the core machine which is a Windows 10 laptop, but I started up Roon remote on my OnePlus6, checked the queue and ensured that shuffle wasn’t on, then went to the play screen and hit play. Then I went back to the queue screen and low and behold, shuffle was switched on and my queue had been shuffled.

Hey Jon maybe we can get @support to take a look at this for you. They may be able to turn on some diagnostics to help to find out what the cause of your issue is.
Good luck

Yes that would be great. I’m not saying it’s not my fault, but I don’t see how!

No Job that’s fair enough, hopefully they can help see what is happening

Hey @Jon_Llewellyn,

Thanks so much for letting us know of this and a sincere apology :pleading_face: for taking this long to get back to you.

In the meantime it looks like @Michael_Harris has been more than helpful. Thanks a lot :pray: !

It may be a bit counter intuitive, but, the way you can turn off Shuffle is to click it again (at the top left of your screen) and then, select undo on the pop-up (at the bottom of your screen).

For more information about Shuffle, see our product manager’s post:

Please, let me know if that helps at all :nerd_face:

1 Like

Hi Rebeka, many thanks for your reply to my issue.

My issue is with shuffle turning on randomly, without me touching the shuffle button. I even checked that shuffle wasn’t on before hitting the play button and saw then that shuffle turned on of it’s own accord and shuffled my queue. It tends to happen when I just fire up a listening session.

Thanks again.

Just to say it’s just happened again, but this time at the start of a listening session using my Macbook pro as a remote. This time both the shuffle and loop buttons activated without being clicked.

This is really annoying, is it me or is this a bug in the software somewhere? @support?

Hey @Jon_Llewellyn,

I appreciate you trying out my suggestion and reporting your findings. I wish that would have done it, but, since it hasn’t, I’ve looped in our technical team.

I’m sorry we didn’t reply sooner - we’ve just returned to work after a holiday weekend in the US. We’re catching up on everything :blush:

Hey @Jon_Llewellyn, when you say that the shuffle button “activated” do you mean that the shuffle icon changes to a purple color, or something else?

What you’re describing is pretty strange, so I just want to make sure we’re on the same page! Maybe you could record a video?

Kevin, many thanks for your help with this. It’s literally just happened 30secs before I’m writing this. There’s no point in a video, it is just like this…

I just had to go and restart the machine my Roon core is on (a Windows 10 laptop) as Roon wouldn’t fire up for some reason. Once restarted, I’ve fired up Roon and left it running. Back in the room where I listen to my stereo, I start up Roon and it connects to the core ok. I go to my queue and always now check the status of the 2 icons in the top right - both loop and shuffle buttons were white. I hit play in the bottom centre and lo and behold, both the loop and shuffle buttons turn purple and my queue is shuffled!

Just to report that tonight I tried using the space bar to start my queue playing and it only activated the repeat, not the shuffle this time…EDIT - sorry I meant the “loop” icon turned purple

Hello @Jon_Llewellyn

My apologies for your thread going cold here. I just wanted to check in to see if you had an opportunity to update to Build 806 and whether this behaviour persists. I’m hoping that it’s cleared up and you’re busy enjoying your music.

1 Like