Shuffle without Duplication Please

In the course of a 40-minute session playing a 155-track playlist, there were three duplicate playings. Tweak the algorithm please.


The same exact piece of media?

And just to confirm, loop isn’t on right? :grimacing:

correct. 10 characters worth of correct.

I have had this happen a few times to me as well.

Hi @John_V,

I’ve moved this post over to #support as there may be some unexpected behavior happening here.

Can you share a screenshot of where you’re selecting shuffle?

Do you have duplicate tracks in the playlist or are these unique tracks that are being picked multiple times?

Can you share a screenshot of the queue after selecting Shuffle?


Afraid I didn’t take any snapshots. This was a playlist (local music only), that I initiated by selecting the shuffle option under the Play button. No duplicate tracks.

Hi @John_V,

When you shuffle in this way, by going to the playlist and selecting Shuffle, the entire playlist should be added to the queue in a randomized order, so there shouldn’t be any duplication here. I tested this out with a few playlists, including some pretty large ones, and things seem to be working okay here.

If this occurs again could you make a note of the time you notice it and respond here with the timestamp? Please also provide some screenshots of what you’re seeing and we will take a closer look.


This seems to happen pretty often if you let Radio play for a few hours. It should be pretty easy for the Roon staff to reproduce.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.