Shuffled Queue across multiple formats experiences frequent stops playing back over AirPlay

Roon Core Machine

Synology DS918+, Intel Celeron J3455, 8GB RAM. Roon uses about 2GB of RAM when running, and total system memory utilization is typically 35-45% (not using memory compression, but having that on or off doesn’t make a difference). Never more RAM usage than that. Roon typically takes 0.4% of CPU, rarely taking above 2%. Not running anything other than the basic DSM install, Audio Station and Roon on the NAS. AudioStation not in active use during any of this.

FWIW, have experimented with having Roon database on spinning internal RAID; USB3 external SSD; eSATA external SSD; all with same results. eSATA external SSD is the current configuration.

Networking Gear & Setup Details

pfSense+ Router/Gateway; Cisco Catalyst 2960G 24-port switch; Cat 6 Ethernet (professionally installed, terminated, tested); 2x Netgear WAX218 access points (although I had this problem employing other access points as well).

DS918+ is 802.11ad LACP to Cisco 2960G (2gbps bond).

Connected Audio Devices

Main system: four input paths:

  1. DS918+ → Ethernet → Auralic Altair (streamer/DAC) → Analog out to McIntosh MA8900 (works perfectly, always)

  2. DS918+ → Ethernet → Auralic Altair (streamer only) → USB out to RME ADI-2 DAC FS → Analog out to McIntosh MA8900 (works perfectly, always)

  3. DS918+ → Ethernet → Windows 10 Pro box running Roon Bridge → USB out to McIntosh MA8900 DA2 module over ASIO or WASAPI (both work perfectly, always)

  4. DS918+ → Ethernet → WAX218 → Airport Express (AirPort4,107) → S/PDIF out to RME ADI-2 DAC FS → Analog out to McIntosh MA8900 (works perfectly UNLESS using shuffled playlists with mixed file formats)

Secondary systems:

  1. DS918+ → Ethernet → WAX218 → Airport Express in Bedroom (AirPort10,115) → RCA audio out to Boston Acoustics Table Radio (works perfectly UNLESS using shuffled playlists with mixed file formats)

  2. DS918+ → Ethernet → WAX218 → Airport Express in Basement (AirPort10,115) → RCA audio out to Denon DRA-395 receiver (works perfectly UNLESS using shuffled playlists with mixed file formats)

Number of Tracks in Library

39,109 tracks
4,147 albums
2,483 artists
~2TB total files

File formats in collection:

AIFF (20594)
ALAC (9)
DSF (1225)
FLAC (12407)
WAV (50)
AAC (2459)
MP3 (2365)

Description of Issue

Roon on NAS works wonderfully for me, with the exception of shuffled playlists that I play over AirPlay, where playback frequently stops after each song. Doesn’t happen when playing to non-AirPlay endpoints. Anecdotally, it seem to only happen when formats change between songs. I’ve seen this reported elsewhere (roon airplay stops after each song - Google Search ).

Visually, a song finishes playing, then you can see the Roon UI try to play the next song (you see the non-determinate progress bar pinging back and forth for a few seconds), then playback stops. I can resume playback by hitting the play button, every time, but it tends to stop again after each song, especially if the song is in a different format than the previous song.

This never seems to happen when playing a single album straight through over AirPlay.

When this happens, I do see things in the logs like this:

02/20 11:29:07 Trace: [MasterBedroom (AirPlay)] [HighQuality, 16/44 FLAC => 16/44] [100% buf] [LOADING @ 0:00] Uniform - Inspiral Carpets
02/20 11:29:07 Trace: [airplay/client] TEARDOWN was successful
02/20 11:29:07 Info: [airplay] AirPlay device disconnected: AirPlayDevice[DeviceId=20C9D09C6C98@MasterBedroom._raop._tcp.local, Name=MasterBedroom.local, Model=AirPort10,115, IPEndPoint=]
02/20 11:29:07 Trace: [airplay] disconnected
02/20 11:29:07 Trace: [zone] MasterBedroom (AirPlay) received transport control from endpoint integration: suspend
02/20 11:29:07 Trace: [zone MasterBedroom (AirPlay)] MasterBedroom (AirPlay) received transport control from MasterBedroom: suspend
02/20 11:29:07 Trace: [zone MasterBedroom (AirPlay)] Suspend
02/20 11:29:07 Info: [zone MasterBedroom (AirPlay)] Canceling Pending Sleep
02/20 11:29:07 Trace: [MasterBedroom (AirPlay)] [HighQuality, 16/44 FLAC => 16/44] [100% buf] [STOPPED @ 0:00] Uniform - Inspiral Carpets

Just wondering if there is a trick to fix this yet. Thanks.

Postscript: I am a local library only kind of guy. No Qobuz or Tidal.

1 Like

I am experiencing EXACTLY the same issue. Main system via Simaudio Moon works flawlessly. Secondary via Airport Express can’t handle shuffled playlist playback. Thank you for posting such a detailed description of the issue.

1 Like

Look for Airport Express in this article. Suspicious to me even if they say Airplay is fine.

Yeah none of that is what is going on with me. They are talking about using them as routers, which I am not doing, nor would I ever think of doing. Thanks though.

Seems to have issues only when the Airport Express is in your audio path though. Just googled Airport Extreme + Airplay problems… lots of discussions about that. I don’t think Roon will be able to fix the problem. Good luck!

When / how do I know what the Roon support team is contemplating this support ticket?

Following up - hoping to hear some questions from @support soon - I tried with a wired AirPlay endpoint today, with the same results, just in case anyone was wondering.


Sorry to hear about your troubles here, I’m noticing a few things that are commonalities here.

Couple questions:

Your problematic endpoints are all have WAX218 access points in chain to the Airport Express. Have you tried removing them and wiring directly to the Airport Express. This may not work for you long term but it provides a permutation for testing that may reveal the issue origin point.

Are you grouping those zones when these issues occur?

@jamie - thanks! I mentioned in a followup that I hardwired one of my endpoints as a test. No difference.

And, no grouping.

Hey @DDPS,

Are you still experiencing these stoppages when using Airplay on the latest version of Roon, Build 918.

If so we may need to consider moving your Core off of that Celeron based NAS. We’ve seen many customers have issues on Celeron and Atom processors. That and the Airport Express devices are a weak point in your setup.

  • To temporarily migrate your Core to Settings >General on one of your remotes and choose Disconnect on the NAS
  • Then choose either This Mac/or PC as the Core
  • Check the underlying issue and see if there’s any improvement.

@jamie - well, I didn’t think to check until you asked, but, well, wow, 918 seems to work just fine!

(FYI - since posting, I had tested to other non-Apple AirPlay devices, like my old Auralic Altair, with the same result.)

But for now, this seems to be working great. I will keep trying for a couple of days and update again!



1 Like

Het @DDPS,

I’m glad that things are working for you now, hope it holds! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

It seems to have held. I tried a torture test with linked AirPlay zones, and that stops after each song. But that is something I don’t do often, and for which I can use Synology DS Audio (that works flawlessly with 3 synced AirPlay streams!)

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.