Sick of this problem! Roon constantly spinning after 1.8 release: "Applying Library Updates"

Roon Core Machine

Mac mini Late 2014
MacOS Big Sur 11.5.2
2.8 GHz Dual-Core Intel Core i5
8 GB 1600 MHz DDR3

Networking Gear & Setup Details

Roon Core —>
wired to Linksys switch —>
wired to Linksys meshed wifi routers —>
wifi to Linksys meshed wifi router —>
wired to Linksys switch —>
wired to Fritzbox ADSL router

Connected Audio Devices

dCS Network Bridge wired ethernet connection to Roon Core
Onkyo T4070 wired ethernet connection to Roon Core
OPPO UDP-205 wired ethernet connection to Roon Core
Arcam airDAC via wifi

Library Size

Around 25,000 tracks

Description of Issue

My Roon Core is stuck in an endless cycle of scanning and updating. I originally thought that it was just rebuilding the database after the 1.8 update, but this has been going on ever since the update came out. The biggest problem is that when it is processing, the core becomes unresponsive with enormous lag between mouse click and program response. The “Force Quit” window often shows Roon as “Not Responding”. I generally cannot establish a connection to the Core from our other devices (laptops, desktops, phones, etc.). Even if I can by some chance connect from remote devices, the connection is frequently dropped or hangs and the music randomly stops playing. The scanning process always gets stuck at the “Applying library settings” phase.

I tried setting the processing power that was available to the processing of database update and scanning to “Throttled” to try to make Roon more responsive. This did not help. Also, just in case it matters, the computer running Roon Core does not have a storage deficit on its hard drive. The Roon Core machine has been rebooted a dozen times while trying to fix this problem. I was going to try to reinstalling and rebuilding the library from backup, but I saw on the Roon community that this doesn’t fix the problem.

I wish I had caught the following thread a few hours earlier (found it 30 mins after it was closed) so that I could chime in that I was having the same problem.

This has been going on ever since the version 1.8 roll-out. It started happening immediately after the update occurred. There are so many other posts in this community forum about nearly identical problems. I find it very hard to believe that nothing changed. Something HAD to have changed to make Roon Core start hanging up on music files that were never problematic before. Besides, Roon Core already keeps a list of files that can’t be imported, so it already has SOME logic for handling import errors. What gives?

I’m getting really sick of this problem. I fully expected a patch to be quickly forthcoming weeks ago, but here we are. I just want to be able sit down with a drink and listen to music, but I have to play clueless IT guy. This week I got notice that my license renewal payment was made, and all I could think was, “It would be really nice if I could actually use it.”


same issue here. it’s forever SPINNING. I deleted EVERY TRACE of roon including the db. restarted big sur, then reinstalled roon core - it worked. no more spinning :slight_smile:


H - I had this problem since the 1.8 update. After numerous going through support with data logs it was discovered that a music file in my library was causing it. I removed the file and all is good now. Not sure why a file I had since 2017 in my library was not an issue until now but that is the case. For there record it was a file with a russian file name which seems to have tripped up Roon. The support team at Roon should be able to help you out…

1 Like

Hi @Jeffrey_Smedley, sorry for the trouble here! Can you please do the following:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).

Hello Dylan,

Thank you for your reply. I have created the log zip files. To whom should I send the download link?


Hello again @Jeffrey_Smedley

Just wanted to let you know that I received your logs and am forwarding on to Mr. Dylan. Thank you again for your patience and courtesy as we troubleshoot this with you. We’ll be back in touch as soon as we’ve reviewed the logs in detail and have next steps for you. :+1:

1 Like

Alright, now I don’t know which thread we’re using… I’ll post on both.

Hello @dylan and @jamie! Just wondering if there has been any ideas about what I should try or if there has been a music file discovered that is crashing my core. Any updates? Thank you guys for helping me out!
–Jeff :metal:

Hi @Jeffrey_Smedley, this is still with our QA team but we’ll follow up ASAP.

Hi Jeffrey_Smedley, @Dylan kindly took the time out to look into my logs.

But in preparing the logs I restarted my Roon Core which seemed to (partly) resolve my issue — or at least it wasn’t anywhere near as bad as it had been.

Dylan then noticed there were some issue in the logs with DNS lookups, so I’d check that you don’t have any AdBlocker software running at the network level and that your using a known DNS server like or on your router (at least for testing).

In my case I was using Cloudflare’s address for my Roon Core (hardcoded), RPi Endpoints (hardcoded) and for my upstream DNS on my AdGuard server. But my Mac (running Roon Remote) was using a local DNS server (AdGuard) and while that wasn’t causing issues elsewhere and wasn’t (obviously) blocking any Qobuz or Roon connections it was something I had forgotten to disable before reporting my issue.

So in short, I’d first double check that you are using a common/widely used DNS server like or on your router, core, endpoints and remote.

For me the issue seems to have resolved itself, so hard to know for sure if it was an issue with Qobuz, Roon, my local network or external network routing to Roon or Qobuz’s servers.


Fixed it myself, thanks. Add some logic to the database updating procedures to kill a process that is hung up on a corrupted filename or directory. Would have saved me months of frustration.

Bad data of any kind shouldn’t hang up or crash a program.

When it does, it’s because of lazy coding.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.