Signal path downsampling to LUMIN D2 streamer


I’m using Roon core installed on my Windows 10 desktop PC. LUMIN D2 streamer and a QNAP NAS for local music files also Tidal and Quboz for streaming services.

I’ve notice that when playing Hi Res files either from Quboz / Tidal or a local hard drive the Roon signal path indicates a donwnsampling process prior to reaching my Lumin streamer-DAC to: 44.1khz 16 bits.
I wonder what’s the point?? I lose all the Hi Res advantage!

Why not let my Lumin do the Hi Res conversion which is praised for!

I wonder if this can be modified in the settings somehow.

And is there a hardware brand/model DAC that can take a native digital signal via Roon and process it by itself?


Check your Roon settings for your Lumin to make sure you are not limiting the resolution.

There’s definitely something wrong in your settings. I’m using a D2 and am upsampling from Roon to DSD128, so all the D2 sees is hires.

Check if you’ve added the D2 as a Room Ready device. I don’t think you have. Based on your limitation to red book, I’m assuming that you’ve configured it as an Airplay device instead.

In Lumin app please disable Lumin Streaming (AirPlay), and custom resampling. Enable Roon Ready.

In Roon setup audio, find Lumin D2 under Roon Ready device, enable it and assign it a name. When playing, select the Roon Ready zone. Do not use AirPlay.

Thanks, I hope I configured it right. Got the purple dot :ok_hand:

Thanks, I hope I didn’t miss any settings this time
Is it possible to attach a screen shot of my configuration to this post?

Yes. Use the 8th ICON from the left at the top of Reply menu.

Attached screen shots settings