Signal Path MQA description

I am a little confused by the use of MQA in the signal path, as well as the resulting blue dot showing signal manipulation on that account.

Case in point is this comparison:

First instance is a real MQA file (from Tidal).

If I read this correctly, the MQA authentication (i.e. “first unfold” is done by my Roon core (Nucleus+) before being sent to my roon-ready DAC (Brooklyn Bridge). And after reaching the DAC, the full MQA decoding (i.e. “second unfold”) takes place in the local DAC process that renders it to its final analog signal, where the blue dot also comes into play - showing a manipulation was done to the steam.

(btw, is this correct? MQA formal terminology usually refers to the first unfold as decoding, and the second one as rendering, which isn’t fully compatible to the above terminology - but I am guessing that is what is in fact happening?)

Second instance is mystery to me. this is a regular file that is NOT an MQA file (FLAC 44.1kHz 16 bit from Tidal, i.e. standard CD quality):

Indeed, as expected, Roon doesn’t do any manipulation to the steam, since there is nothing to manipulate. However, this shows MQA decoding on the Roon-ready DAC side (Brooklyn Bridge). That is not correct. I can confirm that the MQA indicator on the Brooklyn Bridge is off (as it would be, since no MQA file is detected). I even disabled MQA completely on the DAC for good measure, and Roon still shows both an MQA decoding, as well as a blue dot to indicate some stream manipulation is done, while none is.

What explains this?

It would be good for this info to be reliable and meaningful as it is so core to the Roon value proposition.

Thank you (and sorry for the long post)

Your description (as you suspect) is not quite correct. Roon is Authenticating the MQA, but it is not decoding it (as it knows the Mytek can do that).

When Roon performs the first unfold (to x2 rate) it is displayed in the signal path as MQA Core Decoder (after the Authentication stage).

From the Roon side is well, but not sure why (if?) the Mytek is reporting back to Roon it has the MQA decoder engaged.

One for Mytek? let’s see what Roon’s @support team to say.

thank you @Carl - the description of the MQA stages makes total sense, got it…!

let’s indeed see what @support says on the latter issue - no MQA should show for non-MQA files (especially as Mytek device isn’t itself showing MQA on display; and even when I purposefully disable MQA on that device)

many thanks

The second stage is a Render stage, not a decoder stage as no new information is unpacked. It is a filter choice, maybe a sample rate change.

Mytek had a feature that once the MQA process is engaged, it is then applied to non MQA PCM, until MQA processing is manually turned off. This might be what is being shown. Send a message to Mytek and ask.

Hi guys - I did what solves 99% of tech problems - I rebooted the roon core…

now non-MQA files no longer show MQA and problem is solved.

I do find myself rebooting the core about once a week to solve an issue. it feels so 1990s…

thanks a lot for your help, and insightful comments along the way! I learned some stuff here


After another day, I am now seeing MQA files playing with purple dot, instead of a blue dot.

Same gear (Nucleus+ with ethernet connection to roon-ready Mytek Brooklyn Bridge). Tried to reboot both Nucleus and DAC to be safe.

What I got before:

What I see now:

Why am I know longer seeing “MQQ Full Decode” on the end point, and blue-dot to indicate MQA? (I can confirm the Brooklyn Bridge shows MQA on its screen for the file, so this is on Roon end)

thanks for any advice…

Not exactly related but I see the purple dot instead of Blue on an MQA studio file if the Roon Core does the first unfold. This happens if I have my Meridian 210 synced to a Bluesound pulse flex zone.

These observations are the same as this thread:

No. In case of a Roon Ready product, Roon Signal Path just shows what is reported by the RAAT endpoint. If you think the signal path is incorrect for a Roon Ready product, it would have to be handled by your Roon Ready product manufacturer.

1 Like

@goldwerger you have done very much the same observations as I have with a Manhattan II I have on trial. As @wklie pointed out, this is on the endpoint’s side, I opened a ticket with Mytek support to see what they have to say. They are using a third-party network module from Conversdigital but hopefully they can resolve this.

Everything is playing correctly on the Mytek, it’s just the reporting back to Roon that’s really mixed-up.

In your first post I see something in the path I haven’t come across so far, it doesn’t look right; the file is MQA Studio 96kHz, yet the Mytek’s ”MQA Full Decoder” reports ”MQA Studio 44.1kHz”.

Also, when MQA is enabled on the Mytek, it will use that filter also on all regular PCM and you’ll see the ”MQA Core Decoder” stage in the signal path like this:

@sohe68 - thanks for sharing. It does seem to be a similar problem.

I just tried something different - hard reboot of the Mytek unit (after putting in standby, taking both power and ethernet plus out and reconnecting, then starting fresh). This seems to have solved it and I have the blue dot again.

That said, I don’t have confidence it will last, as the integration is clearly not as goo as intended. This isn’t “roon ready” in the full sense, only 95% so - the signal info is clearly not working well.

I am not sure if this is on Mytek side or roon - but it would be good if they solved it, as clearly this is affecting multiple people on multiple models, including non-Mytek gear (see @Chrislayeruk post above as well).

@support ?

No. The way his equipment chooses the color for the LED display is unrelated to the issue in this thread.

His observation is about different colors for MQA stream and Core decoded stream (technically known as MQB), and whether his equipment is able to do MQA Rendering given a MQB stream. The issue in this thread is about having MQA in the signal path or the consistency of it even when not playing a MQA file.

1 Like

Thanks for clarifying @wklie

With better focus on issue, would be great to get @support input re Mytek devices as this seems to affect a couple of us with different Mytek models

Thank you all

From Meridian 210 manual:

Green: MQA Authenticated
Blue: MQA Studio
Magenta: MQA Core

This probably means it is operating correctly.

1 Like

Hello @goldwerger, and thanks for your report! I’ve sent this information over to our device team for testing and will return with their feedback!

Thank you @nuwriy - would really love to solve it, very much appreciated!

Hello @goldwerger,

Your hypothesis is correct, this is an issue with the device reporting its Signal Path status back to Roon. Fortunately, this will have no impact on the sound quality during playback.

We’re going to reach out to Mytek and get this resolved.


1 Like

thank you @john much appreciated (I suspect there needs to be some more thoroughly QA on their roon-ready certicication to assure consistency)

@john @nuwriy - I can confirm after multiple tests that the only way the signal path shows correctly (render stage, i.e. “MQA Full Decode”) on the Broopklyn path end, with blue dot to accompany, is by hard reboot of the unit - by disconnecting it from power source, plugging it back in, and playing the same song (wtih exact same setup), that until that reboot was lacking that stage in the signal path and was shoiwng a purple dot.

This will hold for a few minutes or a few tracks, and then revert back to showing MQA with purple dot and without reflecting the local MQA rendering (even though the Brooklyb’s local LCD display will show MQA).

This is extremely bothersome, since when I listen on roon, I don’t stare at the small screen of the DAC, but I use the roon interface to inform me what is playing and at what quality.

I purchased the Brooklyn Bridge ($3,000 investment!) because I relied on YOUR knowledge base and certification, confirming your in-house testing of the device:

This is more than a little dissapointing - I hope you can resolve this ASAP.

Thank you very much, and have a great weekend

In your pics, the mytek outputs are different. Just using headphones does it change signal path info?

@Rugby this issue exists regardless of whether I output the signal to headphones or speakers.