Signal Path when DSP disabled

Core Machine (Operating system/System info/Roon build number)

Roon Build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Fiio M11, build: 1.1.0 connected via WiFi network with Roon Remote (as Roon endpoint?)

Description Of Issue

Why, when all DSP settings are disabled, does Roon resample bit depth and bit rate?

Welcome to the forum, @Nathan_Leach!

I believe the Fiio is an Android device and these normally resample, so Roon does this by default because it can do a better job.

Hi Martin, thanks for your prompt response.

Yes, the Fiio is Android version 7. Can you tell me how you know Roon resamples by default in the scenario you are preposing? In the desktop application, hovering the mouse pointer over Bit Depth / Sample Rate Conversion (in the signal path) the note tells me this is done because of the settings I’ve made to the DSP, which I have disabled.

No DSP is set and the source is MQA 96kHz yet the output is 196kHz. That device will upsample to 192kHz regardless of source, so Roon does this first. This is why you have the high quality (green dot) indicator.

I saw the same behaviour with my Android phone feeding a Chord Mojo.

1 Like

I’m not sure about that, Martin. I say this because I am experiencing issues where Roon device settings don’t seem to be applied onto the M11 when I change them, this is evidenced when the signal path does not alter when these changes are made. Another problem is upsampling does not change between 88.2 or 96kHz for the first unfold by the Core Decoder BUT for some strange reason I can force this change when I exit Roon remote and play directly from Tidal on the M11. I wonder if this is because of two-way communication between Roon Remote and the Core server, maybe a Fiio bug??

Roon is detecting an Android device so it is giving the best quality signal possible for the hardware.

Let’s walk through the signal path.

  1. Source 48kHz 24bit MQA 96kHz, i.e. a 48kHz FLAC file
  2. Autenticated MQA 96kHz
  3. Bit depth conversion which is needed for accuracy when upsampling

Note that there is no step for MQA core decoder–what are your settings for the device? I assume you have this set to decoder and renderer?

  1. Upsampling to 192kHz which is what Android will do with the signal (and Roon does a better job)
  2. Bit depth conversion back to 24bit

At present Roon+Android gives you high quality signal path only unlike the Fiio’s player and other apps such as TIDAL. You won’t get bit perfect with Roon [and Android] just now.

1 Like

@Nathan_Leach this is completely expected behaviour for Roon on Android devices. As all Android devices are not made equal and all do some different things. Android Audio by default resamples all audio to one sample rate according to the DAC in the device. This is normally 48/24 but can be higher. Some DAPs have managed to bypass this inbuilt Android feature to get bit perfect playback but not all apps play ball. Roon won’t by design for stability across Android it will resample based on what Android OS tells it is the native Raye of the DAC, this is different per device. I have Hiby DAP and it won’t go higher than 44.1/24 without resampling as that what it reports. My phone is always 48/24. If it reports higher than the incoming rate it upsamples, higher down samples. This is how it is on Android. Before Roon did this it left it up to the OS to decide and it was terrible playback problems for most users so this was the fix.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.