Skipped tracks on importation [Resolved]

I’ve imported all of my 19900 tracks successfully into Roon with four exceptions. These four tracks failed to import on the grounds that apparently Roon failed to extract the tags. I have removed the offending tags manually and rebuilt them from scratch but Roon give the same ‘tag extraction failure’ as the reason for not importing those tracks. What’s going on here?

Hi @Alan_McMillan

There might be an underlying issue with the format of those files. Try using say dBpowerAmp to perform a batch conversion FLAC to FLAC transcode. (Assuming they are FLAC, or original format if not.)

All these tracks were ripped using dbPoweramp and were never as issue with Asset, which I previously used when I had a Naim ND5-XS streamer. One of them is actually the fourth movement of a symphony ripped from a single CD at the same time as the other three tracks, all of which were imported without issue and show up in Roon exactly as they should. Could the files in question have been corrupted in some way by the importation process and the ‘tag extraction failure’ is actually not what has happened?

No, Roon never touches your files. As @carl has stated, it is very possible that certain files ARE corrupt, usually some header information is off, but that other players “let them pass” so to speak. I had one FLAC album that played perfectly in other players yet would not in Roon. Used dbPoweramp to resave it from FLAC to FLAC and then it worked. That is what Carl is suggesting you do. Give it a try first, easy and quick to do.

I’ll give it a go and report back.

Hi Rugby
I tried your suggestion and it didn’t work. The file still couldn’t be seen in Roon. I had to re-rip the disc to get the offending track to behave itself.


1 Like

Hey Alan, I’m glad to hear that re-ripping fixed things for you. What track was it?

Hi Rugby
Hyperion CDA 66062: Bruckner motets, Corydon Singers under Matthew Best, track 7