Skipping/Hiccuping with Groups


I seem to have a skipping/pause problem mainly when I do a group. I currently have a raspberry pi connected via cat 5e to router. Mac Mini is running the core and is also hardwired with cat 5e. I have another raspberry pi connected via wifi upstairs. All the music is stored on an external usb 2.0 hard drive. I believe the slow hd connection causes some problems. The wireless pi only has a problem when connected as a group or if a file is loading slowly (slow hd). If I run the wireless pi by itself it doesn’t skip/hiccup. Added the wired pi as a group seems to cause it. I know wifi isn’t the best option but it’s my only option at this point. New house in a few months will have all wired endpoints. The music in a group goes out of sync fairly quickly because of the skip/hiccup. Strange the wired pi doesn’t also skip.

Any thoughts would be greatly appreciated.

Maybe copy a few songs directly to your core. Establish another Watched Folder. Run your group again.

Hi Mike,

Tried that without any luck. I’m going to bring the wireless down and connect it hardwired to the main system and see if it’ll still do it.


I guess then you eliminated that your external HD connection is the issue.

I believe it’s still an issue. As roon will stop mid song and say file too slow to load. I’ve only ever noticed it when playing one song from the core to the wireless pi.

I moved the wireless pi to the same room as the core and wireless router. Haven’t noticed anymore skips or hiccups while grouped. Strange that it’s only a problem when grouping and being further away from the router. Roon will advance to the next song at random. Possible it’s the slow hd, just haven’t seen the message popup. Is it possible to look at logs and see why it advanced?

Hi Benjamin,
If you’re not experiencing the problem with the WiFi Pi in the same room as the router, but are getting it when you take that Pi to the room further away then it sounds like a WiFi signal strength issue.
What WiFi router are you using ?
You might look at tasking another router (a good job for the old router when you upgrade) as a wireless bridge in the room further away. It will usually have a better aerial and receiver than a WiFi dongle. You can then hookup the Pi to the bridge router by Ethernet. This should also improve signal strength for any other WiFi devices in that room.

Hi Andy,

After I played a full album I started to receive the same problem toward the end. Posted too soon. :slight_smile: I then turned off the pi’s wifi and hardwired it. Only difference now is one pi has a pi-dac+ and the second is connected via usb to the PS Audio Sprout’s dac. I switch back and forth to make sure they’re still sync’d. I’ll have to look at the router tonight and see the model. It’s a provided TWC modem/wireless router. My only other router is an older Airport Extreme which I will also try if all else fails.

I was able to see the file loading slowly again message. A few times roon would just stop altogether. Like a song hadn’t even been selected. Seems as if it’s partly because of the wifi distance as well as a slow external hd. Will add a second internal hd to the mac mini tonight and move the library over.

Latest update -

Mac Mini has album on desktop, same harddrive as Roon (Samsung 850 Evo SSD). Both raspberry pi’s are hardwired to an Arris TG1672 router. The Mac is as well. Still getting dropouts playing AIFF files. One Pi has a pi-dac+ and the other is connect via usb to a PS Audio Sprout. Both Pi’s seem to drop.

Mini is a 2.3Ghz Intel Core i5 with 8gb of memory.

I have a second pi+dac that i will install on the other pi so everything is exactly the same. But first I will switch out the router to an older airport extreme (non-tower).

Any other thoughts?

Have you powered cycled your router lately?

A few weeks ago. Problem was there before and after the restart.

Added the airport extreme to the handle wifi and hardwired connections. The TWC modem has been switched to bridged mode. Still getting the same hiccups/pauses with the grouped pi’s. I have not notice any problem when playing a single pi. Haven’t tried two pi’s at once playing different tracks.

Below is the error notice I get in Roon. Now I’m really at a loss. I could try switching the core to a more powerful machine but the Mini already exceeds the specs.

Are jumbo frames turned on/off in your routers ?

Hi Andy - i’m not familiar with jumbo frames. Do I want them on or off? From what I’ve read the airport extreme supports it, but I’m not sure how to check, turn on/off. The arries might. Is it the same thing as MTU?

If I use a switch such as this one… would It not matter whether the router supports? If supports jumbo frames of 9kb.

Hi @Benjamin_Schramm ---- Thank you for the report and my apologies for the troubles here. I wanted to touch base with you as I had a chance to to meet with my developers today to briefly discuss this issue you are experiencing.

As per my conversation, I would like to gather the following information from you. Please see below.

  1. What generation of raspberry pi are you making use of in your setup?

  2. What distribution do you have installed on the units?

  3. Are you noticing this issue when specific content is being played? If so, can provide insight into the bitrate/sample rate of the content?

  4. Can you verify the type of SD cards in the units? Are the all the same or are they varying?

  5. Have you tried switching Pi configurations? You mention in on of your posts:

“Only difference now is one pi has a pi-dac+ and the second is connected via usb to the PS Audio Sprout’s dac.”

If so did you notice any change in behavior?


Hi Eric,

  1. The newest - Raspberry pi 3

  2. Pi with Pi-dac+ has the image from Iqaudio. The image right before the current. Will update. USB’d pi has Raspbian Jessie Lite - 05-27-16. I believe I’ve done the updates through terminal.

  3. All files I’ve been trying this this are AIFF cd quality. I’ve also tried some DSD just to push everything.


  5. I haven’t Two week old is taking up a lot of time :slight_smile: Will update both to the current IQaudio image and try with the same pi-dac+

Thanks a bunch!

1 Like

Hi @Benjamin_Schramm ----- Thank you for the follow up! I look forward to hearing any further observations you make after the update(s). Congratulations on the addition to the family!


Thanks Eric!

Good news. I reinstalled the latest iquadio image on both pi’s and used pi-dac HATs on both . Played perfectly with no hiccups/ sync issues for 4 hours. I then ran Roon all night using the radio and everything was in sync in the morning. The only thing I notice was three songs in a row played 0%, 5%, and then 10% at some point during the night (time machine may have been running at that time). All music stored on external connected via USB 2.0. Seems the problem was the images on the pi’s. I will try and do one with the pi-dac+ and one usb today and see what happens.

Any other tests/configurations I should run, let me know.

1 Like


Installed Roon Server on the mini to try and make it a bit easier on the mini.

It seems if I have I only use one networked endpoint I don’t have a problem. Or if they are the same end point (per above). ie raspberry pi with pi-dac+ x2. I went back to one directly connected to the Sprout via usb and the other via pi-dac+ and they would go out of sync and have a slow file notice with an advance to the next track.

I have now connected the PS Audio Sprout, Audioengine A2+, via USB to the mac mini. No problem as all, played for 3+ hours straights without a hiccup. I also have the mac mini internal speaker in the group for fun. No problems at all. Stays in-sync and doesn’t advance to the next track. So it seems I can pretty much rule out the external hd as a problem. Is it possible the ethernet network card in the mini is having a problem? I don’t notice a problem while surfing the web though. The main problem now is not playing the whole song. 5%, 10%, 50%, etc. The usb connected pi does out of sync too. But the pi-dac+ would stay in-sync with the A2+ speakers connected directly to the mini.

So it really seems the problem is when a raspberry pi is connected to an external dac via usb. Same behavior whether connected to the Sprout or A2+ dac. I looked at the cpu load and power supply load while in operation and everything is at almost idle. Really don’t know what could be causing it. I’m ordering another pi today and will run this:

Coreaudio - Mac Mini internal speaker
A2+ speakers connected directly to Mini
Pi w/ Pi-Dac+
Pi w/ Pi-Dac+

Pi External Dac - Will add and remove the third pi and see if it’s still the problem child. Is there a limit to a grouped amount?

For good measure I’ll also try a roon bridged macbook pro wirelessly.