Skipping! I'm sick of it

Core Machine (Operating system/System info/Roon build number)

Intel NUC i5, Roon build, latest as of 6/10/2020

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Google MeSh

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim Uniti Atom

Description Of Issue
Stuttering playback. Large FLAC collection of about 24K tracks on QNAP NAS. Playback stutters, not on Foobar or Windows media player. Changed core to my laptop and back to the NUC. No difference.

Laptop local playback on Roon stutters too. Doesn’t happen with Foobar. Perfect playback from Dell G7 laptop to Naim Uniti Atom via USB on Foobar.

I have a full FLAC backup on my laptop. Plays great on local output via Foobar and USB to Naim. Stutters on Roon.

What happens if you have your NAS, Core and endpoint connected via LAN cable and not wifi? When did this start?

More network details and a diagram might help you and us see what the issue is likely to be.


Hi @Thomas_Salmon,

What happens if you load up a few albums on a USB drive and connect it to the Core, temporarily bypassing the QNAP? Do the albums on the USB drive play as expected? What about TIDAL/Qobuz content (if you have these services)?

I’ve not tried that yet, but Foobar plays perfectly over the wireless network from either my NAS or my laptop. Roon seems to be the only common denominator.

Hi @Thomas_Salmon,

Yes, I understand that Foobar works as expected, but Roon is a bit different as the processing happens on the NUC Core before it’s sent to your Atom.

We should try removing variables here and testing with the media directly on the Core allows us to eliminate the possibility of the QNAP being slow to deliver the files in time to the Core via the network.

Do you have the latest firmware on your Router and Atom? Have you tried TIDAL/Qobuz and do they have the same issue?

1 Like

All of my drivers are up to date. Since I posted, I’ve switched the core from my NUC to my laptop. No difference. Switched back to the NUC once again, same results. I’m not a subscriber to Tidal or Qobuz.

I signed up for the Qobuz trial. It plays each track for 2-3 seconds and then stops.

Why are you playing by usb to the atom?
It is fully roon capable via the network.
I have an i5 nuc and an atom and no issues, I would think it’s your network.

I just wanted to see if playing via usb made any difference.

After doing multiple resets/reboots of the QNAP, NUC, and router and making sure all components were up to date (all already were), I decided to do a reboot on the Atom by unplugging it and plugging it back in. Now the NAS and Qobuz play perfectly on the Roon app. I decided to reboot the Atom after I discovered a seldom used Sonos player was unaffected. The question now becomes: Why did the Atom play fine over Foobar, but not Roon? Is this a problem with Roon’s integration with Naim, or the other way around? Any thoughts?

1 Like

Different interfaces so one can be working whilst the other isn’t

Hi @Thomas_Salmon,

Glad to hear that the reboot of the Atom sorted things out here!

It is possible that you were using different drivers when communicating with the Atom via Foobar, one on ASIO, one on WASAPI or WASAPI w/ no exclusive mode.

In any case, glad to hear that the issue was resolved after the reboot. If there are further issues, do let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.