Skipping Qobuz hi-res tracks (192/24) [Ticket In]

Roon Core Machine

i7 4x3Ghz
8GB RAM
128GB SSD RAID
Linux Mint 21 Xfce.

Networking Gear & Setup Details

All wired via Ethernet directly to Router. Super stable network connection. Never had any issues with it.

Connected Audio Devices

DH80S connected directly to Core.

Number of Tracks in Library

5112

Description of Issue

Every time I try to play Qobuz 192Khz album roon skips all tracks one by one and won’t play the album at all.

In Roon what does you DAC report it can support ? Your DAC doesn’t mention Linux support on their blurb so I wonder if it’s dropping to standard USB Audio Class and not Audio Class 2 which is needed for above 96/24. Do you have Qobuz configured in Roon to allow up to 192/24 as there are a few settings levels? Even so it would normally resample them down to what it can play back and not skip. Does the Roon remote give any messages like loading slowly ?

roon says my DAC can go up to 192/24. The truth is it can go 384/32 I believe.

Qobuz and Tidal is configured to give max output.
MQA from Tidal works without any issue.

Roon remote says nothing. Just skips all the tracks one by one and finish on “nothing playing”.

There wasn’t an issue before. And by saying before I mean roon 2.0 OR latest Linux Kernel update. Not sure…

Hi @Gracjan_Deresz,

Please accept our apologies for the delayed response.

Looking through diagnostics, there are a few possibilities.

  1. There’s a distinct possibility you’re up against a known issue in which our MQA decoder erroneously recognizes some 192/24 files as MQA, often with terminal results for a downstream DAC or DAP. While the evidence isn’t definitive, there’s an uncanny resemblance to several other situations, for example: Certain Frank Sinatra Qobuz Tracks Won't Play in Roon (Ticket In) - #11

  2. There’s evidence that you’re experiencing some common instability in your system that we anticipate being able to improve soon with upcoming regular releases.

Do you have any issues at all with 192/24 local files? You mentioned TIDAL content doesn’t trigger this.

A meager workaround is to play these files in ARC since there is no MQA unfold stage in that app’s playback engine.

Would you mind supplying tech support the following screenshots to help our incident investigation?

  1. Your Device Setup for this endpoint in Roon → Settings → Audio
  2. Your signal path, including the DAC you’re using here.

Thank you for your patience.

So, I have replaced DH80S with Topping D10s and looks like the problem is gone.
Everything is back to normal so I can’t help with troubleshooting anymore I’m afraid!

G

1 Like

Having this same issue with Qobuz hi res files. 44/16 works fine, as does local 192/24.

Roon Core Machine

NUC i3

Operating System

Version 1.0 (build 227) stable

Roon Server Software

Version 2.0 (build 1143) production

Networking

Core connected to Google router via Ethernet

Connected Audio Devices

McIntosh connected directly to Core. Sonos speakers throughout home using wi-fi. Problem occurs with all.

Number of Tracks in Library

11,508

Description of Issue

“Every time I try to play Qobuz 192Khz album roon skips all tracks one by one and won’t play the album at all.”

Let’s help them (Support) get to the root of the problem.

Would you mind supplying tech support the following screenshots to help our incident investigation?

  1. Your Device Setup for this endpoint in Roon → Settings → Audio
  2. Your signal path, including the DAC you’re using here.

Thanks, Gracjan

See screenshots. DAC is built in to the Mac.



Just curious, what does your streaming preference settings look like.
Bottom of the settings: general page.

As below. I think this was the default.

Nothing irregular to see there, was just an idea but that looks fine.

Are these native Qobuz 24/192 tracks or are you using Roon to upsample to 24/192?

And one more thought here.
Under settings:services: Qobuz.
What streaming quality is it set for when you click on edit.

Native. Qobuz streaming is set to Hi Res 24/192.

Sorry, out of ideas then I’m afraid.
Hopefully someone else has something.

Thanks for giving it a shot.

Hi @Brian_Rickerson, @Gracjan_Deresz,

Unfortunately, there’s evidence in logs that you’re facing this issue linked below in my staff post from another thread. Some high-quality Qobuz tracks are erroneously triggering our MQA decoder, breaking playback. While we’d seen supply chain issues with files in the past, in this case, we’ve already worked with Qobuz to confirm there aren’t incorrect MQA tags contained in the source material. This is a Roon bug that we’re tracking and have prioritized to implement a fix.

There’s a ticket in with senior development, and I’ll be reporting progress in the other thread. Hopefully, this will be a quick surgical fix from here as we’ve already pinned down what’s breaking. Thank you for your patience in the meantime.

1 Like

Fantastic news then!
Thanks guys.