Skipping tacks streaming Tidal

Core Machine (Operating system/System info/Roon build number)

Opt core kit
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Cox comm. supplied top tier router modem

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

ethernet to lumin s1

Description Of Issue

I have experienced roon will skip tracks on albums after selecting play on album page or sometimes selecting first track, and sometimes the first few tracks will be skipped? This is happened as long as I’ve been using Roon and I just recently set up a nuc / rock and it’s still doing it… I was hoping the hardware upgrade would be the fix for that, but is not… any suggestions.? The nuc has not been running that long so cache or anything like that would not be the issue. Streaming tidal exclusively. Tidal playlist or roon playlist will often skip several tracks if you hit the next song arrow. Sometimes not always I will get a message saying tidal is running slow oe something to that effect.

Please set your router DNS to, then reboot all the devices on the whole network.

Ok Ill get with my ISP and test that setting asap and update here. Thank you

If that isn’t the issue are you upsampling? I had a skipping issue that was related to upsampling. When I lowered the rate to the default upsampling rate the skipping went away.

Called my ISP, there does not seem to be a way to change the DNS. Up sampling, I wouldn’t think I would have made that choice, however I could not find any settings for that? Please advise. Thanks

Using an ISP supplied panoramic combo modem router.

Looks like there is no option to change the DNS on this box. You’d need to get a separate router and use your panoramic as a modem only in order to change the DNS - which may well be what you need to do in the end since using a non-ISP provided DNS server has resolved this issue for many (including me - in fact it transformed my internet connection).

The issue you describe (Tidal skipping) is almost always due to networking problems and/or issues with the connection to the ISP. Roon core should be connected to the network via ethernet if at all possible.

Yes mine is connected to internet via ethernet. I guess I have to live with it until I change gear, which is never fun.

  1. Please set MQA Capabilities to Renderer Only, and

  2. Test playback of local MQA stereo files available from here:
    2L High Resolution Music .:. free TEST BENCH

Changing gear is ALWAYS fun! :nerd_face:

Changed setting and will hope for the best. Here is my settings page. Everything look ok?

Yes, and please test local MQA file playback.

Setting change not making any difference. Skipping mostly when you choose a new album or song within an album or playlist. Also experience some dropouts from time to time, not overly frequent. Here is an example, just trying to start this album at the first track repeatedly it would jump all the way down to the like the fifth track and these were my Internet speeds at the time.

Does local music file play perfectly?

You having enough internet download speed does not imply Tidal servers / network infrastructure necessarily have the bandwidth to serve to your ISP for your choice of music at the time you want to play them.

If Tidal does not work well for you, please try Qobuz, and vice versa.

If it’s a tidal issue, how would a router setting improve that? Just trying to understand. I appreciate your help.

If you were asking about DNS, my guess is that’s because many ISP DNS database is not as up-to-update as required, or could result in less optimal replies. Different DNS may give different replies to the same query.

However, there is no guarantee changing that would help your case. I just want to reduce potential problem causes.

Yes I was referring to DNS setting. In your experience does Quobuz perform better in regard to my issue or do they have the same or similar issues? I do have my own modem and router that I could test it with but it’s such a pain to change over, and the router wasn’t big enough to handle my house so I would have to get a new router in the end if that was the solution.

Had the same issue last week. Both my Roon core and streamer were connected to the same wifi extender and since I moved the extender closer to the streamer and core, playback is fine.

Yes but I’m connected via Ethernet, not a long distance and using a quality cable

Oh I see. Must have missed that bit. I am thinking that since this was a broadband connectivity issue for me, it must be the same for you. Sorry I can’t be of any help.