Skipping with format/bit depth/sample rate change

The problem began about 6-8 weeks ago- I’ve been trying to isolate variables ever since. When tracks change from MQA to non-MQA, bit depth or sample rate, there is an approximate 5-10 second period of silence followed sometimes by the track playing, but often with the track being skipped (no error message). Skips have been as many as 90+ tracks in a row. In addition, use of iOS devices such as iPad or iPhone to control playback result in skipping and delay being more common. Even changing a setting such as Volume Leveling on/off via iPad/iPhone stops playback and starts the skipping.

My set up: Mid 2012 MacBook Pro (MBP)- 8gb. Always rebooted prior to Roon use. Memory presssure per Activity Monitor very low- only running Roon and Dirac Live. I use Dirac Live (DL) for room correction. I have used both Roon and DL without issue until recently. Output is USB With Audioquest Jitterbug and Wireworld Cable to Cambridge Audio Azur 851D DAC/Pre. None of the above are recent additions or changes.

Is DL the problem? Doubtful as DL performs perfectly using Tidal directly without Roon. Format/BitRate/Sample rate changes are handled flawlessly without skips or delays.

Is the DAC the problem? Again, doubtful as above experience with Tidal. Also, another DAC (DragonFly 1.2) exhibits the same delay and skipping issues when paired with DL and Roon.

How about the MBP Hard Drive? Maybe, but again - all is well with DL-> Tidal vs. DL-> Roon.
MBP USB ports have been reset and all connections have been cleaned with Caig ProGold contact cleaner.

The DAC has been power cycled numerous times. Computer has been connected via ethernet and wireless with same skipping issues. Download speeds are 22Mbps and is consistent in quality with low jitter and zero packet loss during skipping issues.

I’ve tested Roon playback with MQA decoder disabled and enabled with no effect on skipping behavior.

Tracks that are Redbook (11/44.1) play without issue- no skipping or delay.

All settings within Roon are per “Best Practices” regarding single computer and DL.

Tried delay on Re Sync from 0 to 8000ms without any difference in skipping and delay.

Used Optical out rather than USB without any difference.

Do I have a corrupt copy of Roon? How would one test for that? Do I uninstall/reinstall Roon?
If so, how is that best done?

Is there some weird interaction between DL/Roon/DAC? If so, why just recently and are there not others experiencing that same issues?

I would welcome assistance from the Roon Support Team.

Hello @crummwoody,

We have a few reports of Dirac Live 1.x not working with Roon on MacOS. Do you have exclusive mode enabled for the Dirac zone? If so, try playing to the Dirac zone with exclusive mode disabled. If that does not resolve the issue, I would recommend playing to the “System Output” zone and pointing the Dirac Live input there.


Hello @john ,

Thank you for the reply- I will try the two suggestions later today.
That said, don’t disabling exclusive mode and pointing Dirac Live to the “System Output”
a.k.a. “Built in Output” both have negative impact on sound quality?

I played Roon with the exclusive mode disabled as you suggested. No skipping and was able to control transport on the MacBook Pro or iPad.
However, in that configuration, the sound quality is less that with exclusive mode enabled. “High Quality” is significantly short of “Lossless”. Therefore that’s not truly a solution. It also appears that first unfold with MQA does not occur.
Hopefully there is another solution out there.
As I asked earlier, is it possible the Roon program is somehow corrupted?

Hello @crummwoody,

We have been able to reproduce this error with Dirac Live on MacOS with exclusive mode enabled, and there has been a ticket filled with the development team for further investigation.

In the meantime, there are two things you can do to maximize the sound quality of your setup.

  1. If you are playing to system output, use “Audio MIDI” on your Mac to match the sample rate of the media you are playing in Roon. This should avoid any resampling done by the operating system.
  2. Use an audio re-routing tool to link Roon with the Dirac virtual sound card. I’ve linked below a post from a Dirac representative explaining how to do this. As far as we are aware, the Dirac virtual sound card is set to be depreciated with the launch of Dirac Live 2.0, and this is their current recommendation on how to use Dirac with applications that do not have VST plugin support.


Hi John,

Again, thanks for the followup. I am inclined to wait and see what Dirac Live 2.0 offers in terms of VST support. For now, I spent several hours making 16/44.1 albums Primary Versions so Roon will see the same bit depth/sample rate to avoid hiccups as much as possible.
I await the outcome of the development team investigation. Dirac Live with Roon provides truly outstanding sound.
I also have another alternative player that provides great sound quality, but its user interface is well known to be a “hot mess”. Roon is far superior in GUI experience not to mention support.
Happy Holidays!

Wondering if any progress here? Waited for release 1.6- but skipping still continues.
Worse, with new Radio algorithm, Roon will move between format/bit depth/sample rate which results in Radio being virtually unusable for me.
As mentioned before, I spent several hours making my entire library “primary version” the same redbook to avoid skipping- now Radio defeats those efforts. Any way to have Radio only play 16/44 tracks?

Hello @crummwoody,

We have not made any changes in this area with 1.6, the development team still has an investigation ticket open regarding the issue.

For solving your Roon Radio conundrum, I would suggest using the Roon DSP Sample Rate Conversion feature to manually resample your audio to the desired sample rate before going to the Dirac processor. You could also limit the bit-depth of the driver to 16bit in the Device setup screen to avoid bit-depth changes if that causes the issue to occur as well.

If anything changes in this area, I will be sure to reach out and let you know. We have had limited communications with the Dirac team, and I know some investigative work was done in the area and is communicated as such in the ticket. I’m going to schedule this for the next meeting with the development team to get a better idea of the situation here.


Thanks John, I await further information.

John, I implemented the DSP Sample Rate Conversion and bit depth in Device setup as you suggested.
With those changes, I can now use Roon in general and Radio in particular without skipping behavior. That’s a welcome reduction in frustration level- although we both know that is not a “fix”. High Quality output is not Lossless…
When using Roon in Radio for non-critical listening and artist discovery- the above work -around is just fine. When I want the best sound, I eliminate those changes and understand, at present, I have to be aware that changes in sample rate and bit depth will result in skipping.
Hopefully a real solution is coming down the road…

Thanks again for the assistance.

@john any update to this issue of Dirac and Roon not playing well together?
In the 10 months since our last communication, the skipping continues. Sometimes I will play without “dumbing things down” to lower bit depth and sample rate just to test. On rare occasions things will go well, but the vast majority of the time I’ll experience skipping. This is frustrating as it doesn’t happen all the time- so it’s difficult to diagnose.
Also, it goes without saying that I’m missing out on all the tracks in their native Hi-Rez format.
There are a handful of new streamers that have Dirac resident rather than the computer based Dirac. However, I’ve noticed that none of them are Roon Ready as far as I’m aware.
Help is much appreciated.

Hello @crummwoody,

We do not have any news to share in this area at this time.