Slow computer while running Roon App

Core Machine (Operating system/System info/Roon build number)

Win 7 Dell Laptop 8gb ram external usb

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

wifi Netlink

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Connecting to Chromecast via wifi and DAC via via usb (not at the same time or course)

Description Of Issue

Every time I run Roon on my computer from which I play music (not the core), it slows significantly. Even just typing this, the text takes a second or 2 to appear on the screen. Cursor moves erratically, web pages open slowly and video is not playable if Roon is open. Computer is Dell XPS 15, i7 chip, 32gb ram. Is there a way to solve this? Thank you. Sigmon

Hi @sigmon_whitener,

Is this a new install or have you been using Roon on this machine for a while?

What kind of GPU is this device using?

I would also suggest you give more details like cpu and if the system is using an ssd.

WiFi is not going to be helping either if that’s how you are connected.

How big is your music library too? # of tracks or albums?

1 Like

I have been using same machine for Roon app since I started with Roon 2 or 3 months ago and have noticed the problem since then. I have an Nvidia GPU with 4gb (I think). However I can never tell if the machine is using the Nvidia or switches to the Intel graphics chip. Thanks

Are you asking info about the computer i use for the Roon app (the one with the slowness problem) or the core?
I have about 35500 tracks on the core. I am using wifi.

Detail both as remote can have issues as well as core

@sigmon_whitener,

Do you experience slowness on all devices or only the one?

Some additional details about the CPU / GPU would be helpful for this machine.

Are you using GSync or anything like that on this machine?

@dylan Dell XPS laptop using Roon app is only where I have the problem. I have an Nvidia GPU with 4gb. Dell XPS, i7, 32 gb ram. Problem is NOT on core–only on Dell. The Roon app runs fine on my phone. I do not use Gsync.

@sigmon_whitener – Can you try uninstalling and reinstalling the GPU drivers on this machine? Is there any change when doing so?

If not, can you share some screenshots of Resource Monitor when this problem is occurring?