Slow playback, issues with Roon Radio

(Patrick Mensah) #1

I am getting this error too, quite frequently now, and Roon radio does not automatically kick in when an album I have selected has finished playing…

Another problem is that Roon is sloooow in responding when I click “play” for the first time on any selection… it can take it up to a minute or more to respond sometimes. On my network, the usual response time has been instant, so I do not know what is going on… Any helpful input would be welcome. Thanks.

Roon Radio Unexpected Error Limiting to Library
(Noris) #3

Hi @sahmen,

Can you please provide some more information regarding your setup here?

  • What is your Core and how is it connected to the network?
  • What is the model/manufacturer of your router and any switches/range extenders/powerline adapters/ect.?
  • What endpoints are you using in this setup? Is the behavior the same for multiple endpoints?
  • Are the affected albums just local albums, streaming albums or both?

Thanks,
Noris

(Patrick Mensah) #4

Hi @noris :

– The core is on a Mac mini which is connected to my router with an ethernet cable

–The router is an Asus RT-AC87R, and I have not been using any switches or powerlines until only yesterday, when I started experimenting with a newly released Sonore OpticalModule FMC, with my Ultrarendu endpoint… I would like to emphasize, however, that I have been observing the slow playback issues I have reported for more than a week now, and that they do not have anything to do this experimenting with the FMC, which is exclusive to my Ultrarendu endpoint alone at any rate.

– I have that Ultrarendu I just mentioned, a Metrum Acoustics Ambre (the most used endpoint), An Oppo 203, a logitech Squeezebox Touch, The MacBook Pro from which I do most of my controlling of Roon, an Iphone, and a couple of ipads, all of which may serve as endpoints at one time or the other…

The problem can be observed on all of these endpoints (I have only tried a few of them lately, to be honest), but the severity of the slowness varies depending on the time… I have observed the worst of the problem when using my Metrum Ambre, but that is simply because it is the one I use most of the time. After reading your post, I tried the Ultrarendu endpoint, and also tried playing Roon on my iphone XR… The results were similar, although the degrees of slow-response varied from one endpoint to the next… The iphone was the fastest to respond, but it also exhibited occasional brief cutouts of sound, which was probably related to its wireless connection?

Finally, since yesterday afternoon, the slow response seems a little less severe on even the ambre (it is taking less time than it did on Sunday for the playhead to respond when one hits play in Roon, so the severity of the problem can vary with time, even for the same endpoint.

(Noris) #5

Hi @sahmen,

Thank you for providing those details!

Since you mentioned having an ASUS router in this setup, can you please double check to make sure that “Enable Multicast Routing” is checked in your router configuration? In the past we have seen that this option helps with similar symptoms.

You mentioned that the response time is slow for most of your endpoints, but is this behavior affecting both streaming albums and local albums or just one and not the other? Does “System Output” on the OSX core exhibit this behavior as well or is it just the external endpoints?

Also, has anything changed in the last few weeks or so regarding your setup? Perhaps new firmware on the router or an OSX system update?

– Noris

(Patrick Mensah) #6

Hi @noris :

“Enable Multicast Routing” is the default setting on my router, and I have rechecked to make sure it is active and hasn’t changed,.

There is one thing I just did which seems to have restored the responsiveness of Roon to normal, and that is update the OS software on the mac mini with the Roon core. I tested playback of several albums on Roon immediately after the update and the response and reaction times are back to instant or almost, as it used to do before. Now I am detecting zero indications of the slow responses and buffering before playback or delays in the loading of pages that I was experiencing before the update. So this sounds like very good news, so far.

However, as a precaution, I do not want to run any victory laps yet until I have tested Roon playback and confirmed this return to normality through the next 24-48 hours. But what I am seeing now is very good and encouraging, If Roon stays working this way for the next 24-48 hours, I shall consider this problem as completely resolved, and we can close the case. I shall report back if something else changes…

Yours in “cautious optimism” :grin:

(Noris) #7

Hi @sahmen,

Thanks for the update here! I will leave this thread open until I have confirmation from you that the issue is actually resolved, but it seems to be headed in the right direction, I’m keeping my fingers :crossed_fingers:.

– Noris

(Patrick Mensah) #8

Unfortunately, it is back. Today is particularly severe, as I am getting the “Limiting Radio to Roon Library” error signal, although Roon radio does not kick in automatically between albums as it usually does.

Also selections from Tidal or Qobuz are taking forever to load and play. Locally stored rips load and play much faster, although there is some latency there too.

(Noris) #9

Hi @sahmen,

Sorry to hear that the issue is back. I just ran a quick test on my end and I am not seeing the “Limiting Radio to Roon Library” message on my end, can you please provide some more details here?

  • What are you starting Roon Radio off of, TIDAL/Qobuz or Local content?
  • Is it one specific Track/Artist/Genre that is exhibiting this behavior?
  • Is the same issue occurring across all of your endpoints of just one?
  • Can you please note the exact local time + date in your country when you next get into this state? E.g. 11:58PM on 7/3/19
(Patrick Mensah) #10

Well today, I’m seeing a lot of improvement in responsiveness. I should say the last 8-10 hours have been relatively smooth, as opposed to yesterday. I queued up several hours of music early this morning, and Roon is playing through them quite well and relatively smoothly, with a few seconds of occasional pauses between tracks (as opposed to minutes, yesterday)

Yesterday, the responsiveness of both Tidal and Qobuz tracks was excruciatingly slow. That of Local content was relative faster, but far from optimal, and I was getting the “Limiting Radio to Roon Library” error signal rampantly, sometimes even when playing local content smoothly. I am no longer seeing the error signal today–thank heavens–even though the vast majority of queued up tracks are from Qobuz and Tidal.

Yesterday, I was experiencing this problem on only one endpoint, and I didn’t test any others. It is the same endpoint (Metrum Acoustics Ambre) on which things have returned to normal or near-normal today. Next time I experience another round of severe slow responsiveness, I shall test other endpoints too

I am located in Sunderland, Massachusetts.

(Noris) #11

Hi @sahmen,

Thanks for the update and glad to hear that things have started working again. In addition to checking the other endpoints please let me know the exact local time the issues occur in case we need to review diagnostics down the line. Thanks!

(Patrick Mensah) #12

Okay, it is 7:12pm on Friday, here in Sunderland Massachusetts, and I have been experiencing slow responsiveness and getting “Limiting Radio to Roon Library” error signals for about 4-5 hours now. This is happening on my Metrum Ambre endpoint, and on my i-phone XR as well, so I am assuming that it is similar on all other endpoints, for local files, and also for Tidal and Qobuz files, it usually worse for both Tidal and Qobuz files.

***Update it is now 2:00am, on Sunday, July 7th… Just around 12 midnight, I decided to reboot my Roon core mac mini to see if that would improve the responsiveness, and it actually did, to the point of bringing it to normal. I am of course happy to have stability and normalcy back, especially given how severe the problem became before the reboot. What I want to know now is why Roon now requires a reboot of the core Mac mini in order to return to normal and stable functionality. I have had the core on this same Mac mini (which only houses the core and does nothing else) for more than two years now, but this behavior is recent (it dates back to April/May, as I recall).

(R. Neal) #13

I have this problem, too. Went through extensive testing to reproduce it and send logs. Roon acknowledged the problem, no timeframe for resolution.

(Patrick Mensah) #14

Thanks for letting me know. It helps that they are aware of the problem

(Noris) #15

Hi @sahmen,

Thanks for letting me know those timestamps. I have gone ahead and activated diagnostics mode for your account and what this action does is automatically generate and upload a set of logs to our servers for analysis.

I am looking at the log files now and I notice that there appeared to be a few networking issues on Friday around 7PM. I can’t say for sure what exactly caused the networking issues, but they look similar to a VPN or something similar preventing Roon from properly communicating with the Roon Radio servers.

Are you by any chance using a VPN or other traffic-shaping software on your Core (Little Snitch/Bullguard/ect.)? Is your router using the newest firmware available?

(Patrick Mensah) #16

Sorry for the late reply. The good news is that there has been no acting up on this front since that last recent go-round. Roon has been generally and satisfyingly smooth and stable since then.

To answer your question, I use no VPN or any other traffic-shaping software on my Core, and my router is indeed using the latest firmware available.

(Noris) #17

Hi @sahmen,

Thank you for the update here and glad to hear that things are performing better than before.

I will go ahead and mark this thread as [solved] but if the issue re-appears in the future do let me or another support staff member know and we can take another look into this issue.

Thanks!

(system) closed #18

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.