Slow playback, issues with Roon Radio

(Patrick Mensah) #1

I am getting this error too, quite frequently now, and Roon radio does not automatically kick in when an album I have selected has finished playing…

Another problem is that Roon is sloooow in responding when I click “play” for the first time on any selection… it can take it up to a minute or more to respond sometimes. On my network, the usual response time has been instant, so I do not know what is going on… Any helpful input would be welcome. Thanks.

Roon Radio Unexpected Error Limiting to Library
(Noris) #3

Hi @sahmen,

Can you please provide some more information regarding your setup here?

  • What is your Core and how is it connected to the network?
  • What is the model/manufacturer of your router and any switches/range extenders/powerline adapters/ect.?
  • What endpoints are you using in this setup? Is the behavior the same for multiple endpoints?
  • Are the affected albums just local albums, streaming albums or both?

Thanks,
Noris

(Patrick Mensah) #4

Hi @noris :

– The core is on a Mac mini which is connected to my router with an ethernet cable

–The router is an Asus RT-AC87R, and I have not been using any switches or powerlines until only yesterday, when I started experimenting with a newly released Sonore OpticalModule FMC, with my Ultrarendu endpoint… I would like to emphasize, however, that I have been observing the slow playback issues I have reported for more than a week now, and that they do not have anything to do this experimenting with the FMC, which is exclusive to my Ultrarendu endpoint alone at any rate.

– I have that Ultrarendu I just mentioned, a Metrum Acoustics Ambre (the most used endpoint), An Oppo 203, a logitech Squeezebox Touch, The MacBook Pro from which I do most of my controlling of Roon, an Iphone, and a couple of ipads, all of which may serve as endpoints at one time or the other…

The problem can be observed on all of these endpoints (I have only tried a few of them lately, to be honest), but the severity of the slowness varies depending on the time… I have observed the worst of the problem when using my Metrum Ambre, but that is simply because it is the one I use most of the time. After reading your post, I tried the Ultrarendu endpoint, and also tried playing Roon on my iphone XR… The results were similar, although the degrees of slow-response varied from one endpoint to the next… The iphone was the fastest to respond, but it also exhibited occasional brief cutouts of sound, which was probably related to its wireless connection?

Finally, since yesterday afternoon, the slow response seems a little less severe on even the ambre (it is taking less time than it did on Sunday for the playhead to respond when one hits play in Roon, so the severity of the problem can vary with time, even for the same endpoint.

(Noris) #5

Hi @sahmen,

Thank you for providing those details!

Since you mentioned having an ASUS router in this setup, can you please double check to make sure that “Enable Multicast Routing” is checked in your router configuration? In the past we have seen that this option helps with similar symptoms.

You mentioned that the response time is slow for most of your endpoints, but is this behavior affecting both streaming albums and local albums or just one and not the other? Does “System Output” on the OSX core exhibit this behavior as well or is it just the external endpoints?

Also, has anything changed in the last few weeks or so regarding your setup? Perhaps new firmware on the router or an OSX system update?

– Noris

(Patrick Mensah) #6

Hi @noris :

“Enable Multicast Routing” is the default setting on my router, and I have rechecked to make sure it is active and hasn’t changed,.

There is one thing I just did which seems to have restored the responsiveness of Roon to normal, and that is update the OS software on the mac mini with the Roon core. I tested playback of several albums on Roon immediately after the update and the response and reaction times are back to instant or almost, as it used to do before. Now I am detecting zero indications of the slow responses and buffering before playback or delays in the loading of pages that I was experiencing before the update. So this sounds like very good news, so far.

However, as a precaution, I do not want to run any victory laps yet until I have tested Roon playback and confirmed this return to normality through the next 24-48 hours. But what I am seeing now is very good and encouraging, If Roon stays working this way for the next 24-48 hours, I shall consider this problem as completely resolved, and we can close the case. I shall report back if something else changes…

Yours in “cautious optimism” :grin:

(Noris) #7

Hi @sahmen,

Thanks for the update here! I will leave this thread open until I have confirmation from you that the issue is actually resolved, but it seems to be headed in the right direction, I’m keeping my fingers :crossed_fingers:.

– Noris