Slow roon app response with new Nucleus+ on ethernet


I have a bran new Nucleus+ and experiencing slow responsiveness, especially with Tidal content. Would love any suggestions.

Here is my set up:

Roon build:

  • Roon Nucleus+ with OS version 1.0 (build 227
  • Server software version 1.7 (build 610)

1gb internet (CAT 7 cables). All connected via Ethernet:

  • Roon Nucleus +
  • Roon-Ready DAC (Mytek Brooklyn Bridge).
  • Roon app on windows machine (16 core Intel i7-10875H)

Before installing the Nucleus box yesterday (which was a breeze to do), I had the core running on same windows computer as my roon app, and the computer was connected to the DAC with USB.

Following Nucleus installation, I migrated the core to the Nucleus and switched all communications to LAN (Nucleus, computer, DAC all ethernet connected).

While music quality is great - the responsiveness of the roon app has really gone bad, espeically as it relates to pulling Tidal content (my own music files connected via SSD seem more responsive). When it was running locally on the winodws machine it was instantaneous navigation and playback repsonsiveness - but now I have to wait several long seconds when clicking “play” and sometimes in navigating around. Also, when I use the Tidal windows app outside of roon it is very responsive. So new set up seems to introduce a delay in streaming Tidal (though other things may be at play that I am not yet aware of).

My ethernet connection is as fast as one can make this days and otherwise works very well with a complex home automation network. So this seems a roon problem

would be grateful for any suggestions.

Thank you for your patience with a novice…

How big is the library you have connected and how is it connected to the new nucleus core? Perhaps it’s still importing or analyzing that can take some time depending on the library location and size.

The pc you had the core on before may well be much much faster running roon than the nucleus based on the specs you listed.

Thanks @wizardofoz much appreciate the reply.

The Nucleus is a brand new (rev B) Nucleus+ which I got yesterday. I set it up 24 hours ago, and connected a 2 TB SSD to it USB with only 14 CDs (WAV) saved, so it would be super minimal. I have to assume that those have been long imported.

The interesting thing is that I do see my imported library and that actually plays fast. It’s the Tidal library that plays slow - 5-10 second respond to playing a song, or sometimes to loading a search paged.

Given our internet is fast (1gb) and that Tidal outside of Roon works fast, something about the Nucleus set up is slowing it down. I can’t figure out what may cause this :frowning:

How is everything connected? The network topology with equipment models might help.

For example.

Verizon Modem > ethernet > Netgear GS108 >

ethernet > Win10 PC (RoonServer and Music)
ethernet > Blusound Node 2i > analog >AMP

@Rugby it is connect as follows:

Modem (Spectrum 1gb) > Smart modem (packedge RK-1) > network switch 1 > (Netgear GS116) > network switch 2 (Netgear GS116) > CAT 7 cables throughout home

Necleus+ is connected ethernet cable to network switch 1 above
Win10 PC is connect to network through LAN (ethernet port)
Mytek Brooklyn Bridge is connected to network through LAN (ethernet port)

All ethernet ports measured to provide stead 1gb internet speed. Internet connection and data transfer speed are otherwise super fast over the network.

thank you for any advice!

Thanks for reaching out, @goldwerger!

We’ve seen similar behavior occur in the past due to DNS issues — Would it be possible to set the DNS used by your router to Google DNS ( or Cloudflare DNS ( and then reboot the Nucleus and let us know if there is any improvement?

1 Like

Thank you @dylan for your reply - the DNS is already set to

should I just try to reboot it?

I have confirmed my DNS is and rebooted Nuclues

performance is still very sluggish with Tidal - playing a track can be either instantaneous or take 10 painful seconds.

while this brand new Nucleus+ is connected via ethernet cable to 1gb local network, it seems its ability to stream Tidal performance wise is terrible - I was so much better off just having more core on my laptop.

This is definitely the Nucleus slow response to Tidal, as my local library (connected via SSD) is playing quick.

And my local network is currently providing 900mb+ speed to my connected computers.

Is this the performance i should be expecting??

This is your network switch? You don’t have the managed version installed (GS116E), do you?

@Geoff_Coupe thank you

The switch is indeed Netgear GS116 (pic below).

But I just tried to eliminate that but plugging the Nucelus directly to the modem preceding it (packedge RK-1) which is connected directly to the Spectrum router.

The same issue remains - smooth performance with my file library (connected via SSD to Nuclues), spotty performance with Tidal - skipping to next songs means either quick or - more commonly - a 10 second or so delay before the song starts.

Tidal itself, on its own app, is working very fast on same computer. So it’s a Nucleus performance issue with pulling in Tidal streams

It’s very odd - it’s almost certainly a network issue, but what the cause is, I don’t know. I hope that others will have more of a clue than I do. Two last requests,

  • Can you try logging out from Tidal from within Roon, and then logging in again to see if that makes any difference?
  • And, can you post a screenshot of the Web Administration page of your Nucleus showing the network settings?


1 Like

@Geoff_Coupe I tried logging out and back into Tidal within Roon and this hasn’t resolved the issue.

Here is a screenshot of my current web admin page. Thanks so much:

You also seem to be having connection issues to your PC for iTunes - I wonder if you something coincidentally wrong here that is affecting both scenarios here.

Have you tried a different network cable to the Nucleus? or a different port perhaps.

I would also use a DNS setup that includes the router as a additional DNS entry so it would look like

I use a static setup for mine but the DNS server (in your modem/router) should allow more than 1 DNS entry, usually 2 but some allow 3.

1 Like

Taking windows defense off and adding the router DNS seems to have solve the problem!

but it’s hardly safe long run to keep my computer without a firewall and I can’t imagine that’s the recommended solution to all subscribers with Nucleus. Is there a safer/more sustainable solution for this?

(unrelated: I did reply in the other thread regarding the iTunes network access which isn’t resolved, thank you)

do you mean Defender? Or, do you refer to a different program?

If Defender, I have not had an issue with Defender, however, double check the allowed list under “Allow an app or feature through Windows Defender Firewall”, and verify that all instances of Raatsever and Roon are allowed.

@Rugby - sorry, quick typing… typo… yes, meant Defender

Application specific setting was ok - both raatserver.exe and roon.exe were allowed

but only when I turned firewall off did performance work

Hmm, interesting that just turning off Defender seemed to correct the symptom. Just a couple of environmental questions

Did that PC run the full Roon package before you got the Nucleus? Or did you have RoonServer AND Roon installed on the same PC?

Have you had any recent Windows updates or Pending updates. I think there was a Defender update recently in v2004.

1 Like

@Rugby - I previously had the entire software - core and player - on same PC (which PC I’m now using only for player control, having backeduped the server and migrated it to the new Nucleus+ server I got couple days ago.

I’m on current Windows OS V2004 (build 19041.508) which was installed 9/9 - so I haven’t changed the build in the last 3 weeks.

Hi @goldwerger,

If you have already migrated your Core over to the Nucleus, we should try to clean up the remaining database on your PC.

First, please ensure that you have a Backup of your database in place, then follow these instructions to refresh your Windows 10 PC Roon install:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location (on the PC under %localappdata%, not the Nucleus RoonServer location).
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Open Roon and select Nucleus as the Core

Have and ensured that you connected to your network via a Private network, not a Public one and that you have the appropriate exception checked? See this guide for more information on private/public network setup.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.