Slow Roon app since Qobuz service added


#1

Hi @support folks,

Core Machine (Operating system/System info/Roon build number)

ROCK
OS/Version 1.0 (build 174) stable
Server/Version 1.6 (build 401) stable
Wired to an Apple router, FTTH - 300Mbps up and down.

Audio Devices (Specify connection type - USB/HDMI/ect.)

MacBook Pro 15 2017
USB cable to
Schiit Jotunheim with Multi-bit DAC

Description Of Issue

The main UI feels really slow to display the main page and also search results.
Sometimes it is turning into completely unresponsive. A restart on the Roon app on the Mac doesn’t solve the issue.

This is one message I have:

roon-qobuz-load-slow

The workaround I found so far is to restart Roon Server on the ROCK.
While the slowness happens, I check the Roon app and everything looks good.

Any recommendations?


(Noris) #3

Hi @bitonio,

Thanks for contacting us regarding this issue. Can you let me know what kind of hard drive (regular/SSD) you have on the ROCK and what the size of your library is?

Also, just to confirm here, the ROCK is connected to the Apple router and this is the primary router coming from your modem, no other switches/range extenders or powerline adapters are in between the ROCK’s connection to the internet?

How often does this issue occur? Is it once ever hour or once a day? After you restart Roon Server on the ROCK how long does it take to get back into this state?

Thanks,
Noris


#4

I am using SSD hard drive.
I have a small library of 15k tracks / 1100 albums.
The music is stored on a Synology NAS hooked up on the same Apple router. No extra equipment.
I do not have any issue when I am only searching local content (when Qobuz service is off).

The issue occurs almost daily. I’d say after 10 to 25 songs in a few different sessions.
After I restart, I think it last the next part of the day and sometimes longer. The Roon Server had an uptime of 7d when I did the restart.

Tonight, uptime is 2 days, 8 hours, 54 minutes and no problem. I’ll update the thread next time it happens.


(Noris) #5

Hi @bitonio,

Thanks for sharing that info. Please note the exact local time in your country (e.g. 5:56PM) when this issue occurs next time and let me know. After receiving this info, I would like to take a look at the diagnostics from your machine to see if there are any errors being outputted.

One other thing that I’ve seen help with similar symptoms is changing a router’s DNS server from the ISP provided ones to Google DNS or Cloudflare DNS. If you’d like to give this a try can you please let me know if it helps?

Thanks,
Noris


#6

I’ll do as instructed. Thanks


#7

FYI I haven’t report any issue here, but got 3-4, roughly every week I need to restart because it becomes super slow. I haven’t write down the time (was busy doing some other stuff), I’ll try to do it write next time it happens. Last Roon Service restart was 2 days, 20 hours ago.


(Noris) #8

Hi @bitonio,

Thanks for letting me know that the slowness is still occurring. To properly analyze the logs I would need a timestamp and a to know what specifically I am looking for – slow search, pressing album X took 30 seconds, ect.

Any further information that you can share would be helpful in narrowing down the causes.

Thanks,
Noris