Slow speeds copying music to ROCK Internal Storage over network

I have just built a Roon server (NUC8i7BEH, 2 x 8GB DDR4, SAMSUNG 970 EVO PLUS M.2 2280 250GB, Samsung SSD 860 EVO 2TB), updated the BIOS to latest version (0074), installed ROCK, and then formatted the 2TB SSD via the ROCK web admin interface.

I am attempting to copy 12,000 FLAC files (650 GB) to the internal 2TB SSD over the network, but I am facing issues. I have tried both methods of importing music, and in both cases have had extreme slowness.

My computer that has the music to be copied, as well as the Roon server, are both on a wired gigabit network connected to the same switch.

I have attempted to copy the files with Roon Server on and off to see if it would make a difference. It didn’t. In my last attempt, after 3.5 hours it has only copied over 71 files (CD quality with FLAC level 5 compression), and 22 files have failed. A quick test of copying files from the same source computer to my NAS resulted in 182 files copied in 3 minutes with no failures.

I have read other threads on this forum where others have faced slowness, but I am thinking something wrong is going on here. Does anyone have any thoughts as to what could be going wrong?

Thanks in advance.

Have you tried stopping the Roon Server Software on your ROCK system? As a general rule, it’s best to have this turned off before transferring music.

You might want to give SFTP a try. I had the same issue copying from a Mac to ROCK. MacOS doesn’t play all that well with MS SMB(CIFS) which I believe ROCK uses by default to advertise it’s shares. Disabling signing in SMB on Mac helped but still not great and doesn’t apply if running Windows 7 or greater.

FileZilla is a free program with SFTP support, throughput is vastly improved.

Update: I have removed the 2TB SSD, installed in my Windows 10 PC, reformatted with exFAT and tested the copy speed from SATA drive to SATA drive. I copied 165 files (15GB) in less than 3 minutes with no issues. As this is a new SSD, I wanted to rule it out as being the problem. I am now going to reinstall in the Roon server, reformat via the web interface, and try copying files again.

I am concerned there might be some network issue on my Roon server.

Thanks Scott and Larry for the suggestions.

Scott - I tried transferring music with Roon Server Software stopped and with it running and I did not notice any difference in the speed.

Larry - I will give this a try if my current troubleshooting doesn’t yield any positive results.

I have reinstalled the 2TB SSD in the Roon server and reformatted via the ROCK web interface.

Here is copy speed with Roon Server Software on

Here is copy speed with Roon Server Software off

I also tried playing a song to my Roon endpoint (MicroRendu) and I got 4 audio drop outs in 90 seconds. This has never happened with my existing Roon server streaming to the same endpoint.

There is definitely something wrong with the networking on the ROCK. Not sure if it is an issue with the hardware, BIOS, or ROCK OS.

I flashed the BIOS back a version from 0074 to 0073 and ran another test.

It copied one entire album with an average throughput of just over 1 MB/sec. This is better than the 350 KB/sec I was getting earlier, but still not acceptable performance.

I guess I will try version 0071 of the BIOS next.

I flashed the BIOS to version 0071 and ran another test.

I had issues connecting to the file share at \ROCK\ at first, so I deviated from before and directly connected to the file share using the IP address.

I think my average throughput was just under 2 MB/sec. This was a little bit better than on BIOS version 0073, but I am not sure if this is due to the BIOS version, using the IP address vs. host name.

Reverting back to BIOS version 0073 and using the IP address to copy to the network share had throughput averaging below 1 MB/sec.

The oldest BIOS version I can find for the NUC8i7BEH on Intel’s download site is 0071. So I flashed the BIOS back to 0071.

Then I reinstalled ROCK OS from the web admin, reset Roon database and settings, and rebooted.

Copying the same files to the network share (using IP address) averaged about 700 KB/sec.

I tried copying the same files to the network share again (using host name) and averaged about 1 MB/sec.

My test results have been fairly inconsistent, but I definitely got worse performance on BIOS version 0074, and I got my best performance on BIOS version 0071.

The problem is that my best performance configuration for copying the same files 3 different times averaged 700 KB/sec, 1 MB/sec, and 2 MB/sec. I can’t continue forward with this type of throughput.

Should I install Clear Linux to see if I can copy files across the network quickly and try to rule out any issues with the NUC’s network interface?

Does anyone have any other suggestions?

Is anyone running ROCK on a NUC8i7BEH and getting better file copy performance? If so, what BIOS version are you on?

Thanks again,

I’ve moved your post over to Support so the Roon Technical Team can address the problem.
For reference, I just copied some files from my NAS to my ROCK server and I had a transfer speed of 17 MB/s. Not exactly blazing, but it seems you should be doing better.
I’m also concerned about the large number of failed copies. That may or may not be due to having Roon Software running during the copy, but it seems a very high failure rate.
Roon would probably want to know some more details on the network topology. Seems it’s simple, but the switch type could help them.
Sorry you’re having these problems with your new server. Once it gets going they are nearly care-free.

Scott - You are definitely on to something regarding network topology.

I plugged my PC and my ROCK server directly into my router and unplugged everything else.

The same folder with 15 files (738 MB) took less than 10 seconds to copy over.

At least I now know it is something about the network that it doesn’t like. Now I have to figure out what that something is.


Maybe another device with the same IP-address?

Below are a couple of scenarios copying the same folder with 15 files (738 MB):
ROCK to router, PC to router = 10 seconds
ROCK to switch, PC to switch = 3 minutes
ROCK to switch, PC to router = 10+ minutes

BlackJack - I went into my router and set a fixed IP for ROCK that I know nothing else is using and reran the above test, but it didn’t have an impact. Thanks for the suggestion though.

The switch in contention is a Netgear GS608 v2 (8 gigabit ports). I have been using it connected to about 6 devices (including my old Roon server) without issue for several years.

My router is an Asus RT-AC86U (4 gigabit ports). The router is connected to 5 switches, all of which are gigabit. One of those switches is a Netgear GSS116E, which is a web managed switch, but it is not in the chain of ROCK and PC, and I faced the throughput issues even when it was disconnected from the router.

On my router under LAN - Switch Control, Jumbo Frame is set to disabled.

Try with Jumbo frames enabled and about 9MB.

Although I don’t have local storage in my NUC/ROCK, I have no issue moving large amounts of data on my network, whether PC to NAS, or NAS to NAS using rsync backup. In fact both main & backup NAS units have bonded eth0 so 2Gbps with jumbo frames.

Can’t you do the copy externally in another pc while you sort the network issues?

Bad ethernet cable or bad port on the switch? Do the network lights on the switch tell you if it has adjusted transfer rates down to 10 MB/s?

Hi @Jumbleknot,

It definitely seems like there is something going on with the Netgear GS608 v2 in the chain. I would recommend trying to use different Ethernet cables with this switch and see if that helps.

I did some looking around, and I also found this:

There are a couple of similar reports as well. I didn’t see any specific resolution, but there may be issues with that particular switch model that is playing into things here too.

Thank you all for the suggestions. I had tried 2 different ports on the switch with 2 different cables yesterday with no difference. The strange thing is that my old Roon server (sonicTransport) was using this switch 2 days ago with no issue.

When I get home from work tonight I will try replacing the switch and see what happens.


I replaced my Netgear GS608 V2 switch with a Netgear ProSafe GS105 I had in another room. When I attempted the folder copy (same 15 files - 738 MB), the copy averaged 108 MB/sec.

Wow, what a wild goose chase. I have been using that switch for years, and my NUC8i7BEH, BIOS version, and ROCK were all new to me, so it seemed logical to assume the issue was with that combination. It is still interesting to note that I did get worse performance on BIOS version 0074, but I am not going to flash the BIOS another 3 times to test the performance of each on the new switch. 108 MB/sec is good enough for my intended use.

Honestly, thank you all for your suggestions and support.

This has motivated me to replace my entire network with Ubiquiti gear…shhh don’t tell the wife.

1 Like

Glad to hear you got the problem solved.
I wouldn’t call this a wild goose chase. Your approach was very disciplined and got the root cause fairly quickly. Bias is always a force to deal with, and in this case the previous good experience with your switch had you fooled for a short while.
You’ll love your Nuc. Enjoy the music.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.