Slow Startup of Roon App - 55 Seconds

Roon Core Machine

iMac Big Sur 11.6.7, 3.2 GHz Quad-Core Intel Core i5 8gb ram

Networking Gear & Setup Details

Running wifi to a Virgin Media Router

Connected Audio Devices

no connected audio devices. Not running Tidal or third party sites yet

Number of Tracks in Library

16,701 tracks

Description of Issue

Sorry in advance, I suspect this issue is not new but if you could point me in the right direction please. When I click on the Roon app it takes 55 seconds for it to load and be ready to use. After about 50 secs I do see a message saying select an audio zone at the bottom of the screen but that soon disappears and it’s ready to use. I think 55 secs seems excessive, especially as my library will be way smaller than many users here.

Any thoughts on how I can speed this up please?

Thank you

Am I right in thinking that your iMac is the 27" late 2015 model? If so, which storage device is it fitted with (hard drive, Fusion Drive or SSD)? If it’s not an SSD this is likely to be contributing to the startup time.

More generally, Roon isn’t especially quick to start. By way of comparison, my Mac mini M1 (16GB RAM) takes just over 2 minutes, but I have a much larger library than you.

Roon isn’t known for fast starting. It does a number of checks when loading which take time. Slower drives if not ssd will take longer.

Hi DaveN,

Thank you for your reply. You are quite correct. I have the iMac 27" late 2015 model. It has a fusion drive. Other apps open very quickly. I thought I must have something wrong in the settings. Now I know it’s normal I’ll just work around it. Thank you very much

Hi CrystalGipsy,

Thank you very much for your reply. I thought I must have something wrong in the settings. Now I know it’s normal I’ll just work around it. Thank you very much

Not sure how long you have had Roon on the machine in question, but it might help to clear the Image cache (settings\setup) and Clean up the library (settings\library)?

This last one I am not sure if would matter, but you could also try changing the analysis settings (Settings\Library)? Not sure if it needs to analyze in the background during start-up? Giving it more than “throttled” might help?

Hi BearFNF,

Thank you very much for your reply. I can confirm that your advice has helped.

I cleaned the image cache and library. I’ve attached a screenshot of the library. It seemed like it did need a cleanup. I haven’t touched the audio analysis settings yet as it said it does this in the background so not sure if it would help on startup time.

With the 2 cleans you recommended it has reduced startup time by 10 seconds from 55 to 45. So well done! Thank you for your help : )


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.