Slow stream from Tidal

Core Machine (Operating system/System info/Roon build number)

Synology DS918+ , last update. I have the same issue with my iMac 2017 (Catalina) as a Roon core

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Freebox Delta (France)
wifi with apple devices (extreme and capsule)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

chromecast device (Sony TV), Oppo UDP 203, iMac 2017. Same issue with every device.

Description Of Issue

Message from Roon (my translation from French from English) :frowning_face:

“Tidal stream is slow. It could be the sign of a network or connection issue”

It takes a long time for a music track from Tidal to start and then it stops fews seconds after. Then the next track is played, and so on…

Everything’s worked fine before the last week. Catalina issue ?

Bienvenue sur le forum, @Philippe_Colas.

Pour être clair, veuillez confirmer si votre cœur et vos extrémités Roon sont connectés au réseau filaire (Ethernet) ou wi-fi.

Néanmoins, il existe d’autres rapports similaires au vôtre lors de la diffusion et de l’utilisation de Catalina, par exemple.

Roon travaille sur un correctif. Jusque-là, pouvez-vous revenir à High Sierra?

To be clear, please confirm if your Roon core(s) and end points are connected to wired (Ethernet) or wi-fi.

Nonetheless, there are other similar reports to yours when streaming and using Catalina. Roon is working on a fix. Until then, can you roll-back to High Sierra?

1 Like

I doubt this is a Catalina issue. My Roon core is on a synology.
All my end points are connected to ethernet.

Hi @Philippe_Colas,

If you try to stream local library tracks, do you still experience the same issue? What is your download/upload speed, can you check on

local library tracks stream is ok. Quick and responsive.

My speed :
descending : 5,8Mbps
ascending : 0,8Mbps

restart the whole system including the modem

Hi @Philippe_Colas,

Thanks for letting me know your download/upload speeds. 5.8Mbps is a fairly low network speed to stream hi-res content with, and if there are other devices on your network using network bandwidth it will further limit the bandwidth available for Roon to stream content via the internet.

Do you have any possibility of upgrading your network speeds? I should also note that we have seen Apple Routers (such as your Extreme/Capsule) have unreliable performance in the past, as mentioned in our Networking Best Practices Guide, but the network speed should be addressed first and foremost to ensure reliable streaming.

I’m not satisfied with your answer. I have zero issue to stream Netflix, TV channels (Free) and other high bandwidth stream services. Thus, I didn’t have any issue with Roon before (several month of trial and as a regular subscriber).

I have another issue. When I search for new devices, Roon doesn’t stop to search.

Regardless, your internet is very slow for streaming high resolution music on Roon. Try streaming directly from Tidal and Qobuz. Roon may not work for you.

Hi @Philippe_Colas,

Streaming high-resolution audio requires a significant amount of bandwidth, just because you are able to stream Netflix/TV Channels does not mean that your internet connection is up to par for network audio content.

You mentioned that this did work in the past, so there are a few troubleshooting steps that we can try, but I do want to stress that this is a very low internet speed. Here are my follow-up suggestions:

  1. Make sure that your Core and endpoint are connected via Ethernet to the router. Ethernet connections will generally provide better stability than WiFi.

  2. Try fully rebooting your network, Core and endpoints. By a full reboot I mean power off the device(s), unplug the power cable, wait 30s and plug them back in.

  3. Ensure that nothing else on the network is using significant bandwidth. You mentioned you have the TV streaming through the network, is the behavior the same if you don’t have this active?

  4. I would check to see what the behavior is like when using the TIDAL app. The TIDAL app handles buffering differently than Roon, but if this also does not work when sending the maximum quality available to your account, it is a good data point to have. You can configure the resolution in the TIDAL app in File -> Settings -> Preferences -> Streaming -> Quality.

I did all of this. With the maximum quality, Tidal in the Tidal app works fine…

Roon seems to work fine tonight. I will contact you if I have another slow connection.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.