Slower performance since update

It‘s a shame. Loved to show off Roon to my friends. Now, with 1.6 this is not an option any longer.

  • Display is ugly (old presentation of artist without circle was good. Now, less information and lots of white, unused space around.

  • GUI too slow, search for own CDs within collectin much slower than before,

  • Lots of albums now without cover information. Unbelievable

So, the question is, how do we get back the fast responsiveness of 1.5…

Best
Sven

P.S. roughly 7.200 CDs on NAS, core running on MacMini 2012 with SSD …

I’ve experienced the opposite. 1.6 is more responsive than 1.5, though 1.5 was no particularly slow. I just notice a fresher snap now with 1.6.

Hi @Sven_Eschholz,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you provide some specific examples of this? What are you searching for? How long does it take to load? How does this compare to 1.5?

Hi @dylan,
Roon core running on MacMini 2012, SSD and 8gb RAM.
Music stored on Naim HDX (2TB) with 1.5TB in use,
Roon bridge is a Auralic Aries with Chord Hugo2 DAC.
All things connected via LAN cable using a HP Procurve 2810 switch (enterprise level). No changes applied to my hardware set-up since changing from 1.5 to 1.6.

Searching for things I already searched for, I.e. I do know it’s there. Just want to access the cd, e.g. Hans Zimmer. Haven’t checked, but might relate to those where also Tidal based records are added to my library.
Thanks for having a look. Out of curiosity, do have increased hardware requirement with roon 1.6 compared to 1.5?

Best
Sven

Hi @Sven_Eschholz,

What are your typical internet speeds?

How many albums are in your library (TIDAL/Qobuz/Local)

If you do a search for Hans Zimmer how long does it take (how many seconds)?

Can you do a couple of searches and let me know what the search is for and how long it takes?

Thanks!

Hi @dylan,
ISP provides 450mbit…
Tidal <50
Qobuz =0
Own <7,200

Search takes roughly 5sec. Will do some measurements tonight.

Best
Sven

I agree, the 1.6 upgrade is slow, very slow and i’m also disappointed concerning the layout, the previous version was better.
Besides the background color choice, a layout choice would be nice

@dylan,
On average, search takes 3 sec, and that’s just longer than before. More astonishing is that it takes >7 sec for those items which are already displayed as potential choices when you start to type a search. E.g.typing „part“ provides you as the first entry with „Patricia Barber“ as search item. The 4th item suggests „Patrick Smith“ as choice, searching for „Patrick Smith“ keeps you 7.5 sec waiting. You can do that with „wynt“ and will get „Wynton Kelly Trio“ as 4th choice. Searching for „Wynton Kelly Trio“ keeps you again waiting for more than 7 sec…
any further questions?
Best
Sven

I’ve been running 1.6 since the day that it was released. I have 1000+ albums stored on my server and have had an additional 3000+ titles ‘saved’ to my library each from Qobuz & Tidal subscriptions (although I recently have removed the Tidal database). My initial experience was similar to what I see reported in this thread. Very slow and unresponsive (relative to what it had been in 1.5), particularly in searches.

That has gradually changed and improved over time and with continued use (and I use Roon daily). As I write, 1.6 is now just as fast and responsive as it had ever been with 1.5. I no longer experience any slowdowns and never wait longer than 1-2 seconds (sometimes less than that) for any function or click, including ‘Search’ function.

I’m relatively certain that (in other threads) Roon staff have stated that the responsiveness will increase over time and use and that has born out for me. If memory serves, a period of time as much as a week or two was even suggested. Just keep using and (hopefully) your experience will be the same as my own.

@danny
Further thing noted, but different topic.

Got an example where tracks shown for an artist are listed as per Tidal. However, they are flagged as unavailable although they belong to a disc I actually own. Further the own ripped disk is marked as primary. When selecting the disk in question, all tracks (wav) are available. So, nobody can really understand why they are marked as unavailable.
Regards
Sven

That’s a weird situation, I know why it’s happening but maybe we can do better. I can look into this.

@dylan
Further many records and artist do not have a picture assigned while that had before, see example below.
Best
Sven