Slowness on Windows 10 after Windows Update KB4013429

Hi All, just wondering if we’ve had any updates on this? Is installing the 32-bit version of Roon the only long-term fix/workaround currently available? Cheers, Steve

I have the same problem with de HD400. I reinstalled the latest driver and Roon is working normal again. Don’t ask me why!!!

I installed 32 bit version and didn’t seem to help. So did nothing for a week and the next time i opened Roon was working OK

The problem still generally persists although the software-environment changed in the meantime:

  • The Windows Creators Update was instal* led.
  • I installed the latest Intel driver for the Intel HD Graphics 4000 ( from 7-April-2017).

Any help would be appreciated since the user-interface is hardly useable at all (in fact I have to use the iOS app).

Further observations:

Ever since the problem first occurred there have been about 2 Windows sessions that have not been affected by the problem and the user-interface response time was back to normal. Unfortunately I am not aware what circumstances might have caused this.

Have you tried 32-bit Roon?

Thanks @wklie. I reverted to and tried the 32-bit version for some time and the problem has disappeared. Thanks for your hint.

For the last few weeks, not sure how long, my PC has been extremely slow running Roon (maybe from last update?). Like when I shift to “Overview” it takes a long time before pictures are loading. The software is frozen for 10-20 seconds so I cannot move around. If I scroll, I can scroll a bit - then it freezes and I have to wait. It is only in Roon. If I Alt+Tab to Chrome, this will be normal.

My Roon server is on a Mac Mini. The Mac and my iPhone are not affected. Music is playing normally as it comes from the Mac. It is only navigating on my lap top PC.
Hope you can help

Hi @Kim_Jensen ----- Thank you for the report and sharing these observations with. The feedback is always appreciated!

Moving forward, may I very kindly ask you to please provide the make, model, and specs of the mentioned PC where you are noticing this behavior. Please also be sure to include what type of graphics care is being used in the mentioned device.

Lastly, since noticing this behavior have you tried reinstalling the application on the PC? More specifically, if you are currently running the 64 bit version of Roon, have you tested with the 32 bit version?


Hi Eric,
thanks for your response. I haven’t tried reinstalling. Actually I thought it came from a software update and thought there would be a new update fixing it. :slight_smile:
The PC is a Samsung laptop from 2012, I will be uploading a printout from System Information. It has been running Roon for almost a year without problems.
The Mac Mini, running the server, is from 2011 with slightly less specifiications, but it is running smoothly.
Best regards
Kim Jensen

Just want to add that I have installed the 32 bit version and it runs normally. The PC is 64 though.

Hi @Kim_Jensen ---- Thank you for the follow up, how have things been holding up since the reinstall of the 32bit version?

Furthermore, based on the screenshot you provided I don’t see anything pertaining to the graphics card being used. Can you please provide me with this information, as I think we saw similar reports to yours, which we determined were the result of an automated Win10 update + a specific graphics card.


Hi Eric,
Since I changed to the 32 bit version, the software has been running normally. I don’t notice any delays when navigating around. This is my graphics:

Name Intel® HD Graphics 4000
PNP Device ID PCI\VEN_8086&DEV_0166&SUBSYS_C0E8144D&REV_09\3&11583659&0&10
Adapter Type Intel® HD Graphics Family, Intel Corporation compatible
Adapter Description Intel® HD Graphics 4000
Adapter RAM (2,080,374,784) bytes
Installed Drivers igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igdumdim32,igd10iumd32,igd10iumd32
Driver Version
INF File oem3.inf (iIVBM_w10 section)
Colour Planes Not Available
Colour Table Entries 4294967296
Resolution 1920 x 1080 x 60 hertz
Bits/Pixel 32
Memory Address 0xF7800000-0xF7BFFFFF
Memory Address 0xE0000000-0xEFFFFFFF
I/O Port 0x0000F000-0x0000F03F
IRQ Channel IRQ 4294967292
Driver c:\windows\system32\drivers\igdkmd64.sys (, 3.63 MB (3,811,288 bytes), 03/05/2016 23:30)

Best regards and thanks for your help
Kim Jensen

Hi @Kim_Jensen — Thank you for touching base with me and providing the requested feedback.

Ok, so the graphics card you are implementing matches up with what was reported here. My assumption is that you are experiencing the same issue (graphics card + WIN10 update).


Yes it could be. In my case i is not so long time. I guess I noticed when I was back from vacation, beginning of August. I had been gone since mid July.

Roon software was running extremely slow on my Windows 10 pc (yes with intel graphic card)
I have first installed the latest driver for the graphic card but this did not make any difference.
I have then uninstalled the 64 bit R00n software then installed the 32 bit version and it now runs normally

Where did you find the latest driver from - Intel website or Microsoft updates?

I updated from the device manager by selecting the graphic card then select update latest driver. however it says the driver is up to date and reinstalls the same driver. the version is and is a 2015 year driver.
is it really the latest driver? or is there a more recent one in intel website?

For the latest driver I believe you’d have to go to the Intel website, regardless of what Windows tell you. However, if everything is working fine with the 32-bit installation in your setup, there’s no need to change things further.

Using the 32-bit version of Roon provides a stable & reliable fix if you have “Intel® HD Graphics 4000”.
This is what I’m doing on my Desktop PC, which has an i7-3770K processor and runs Windows10 Pro 64bit.

Bear in mind that if Windows updates itself - and there’s another major (Autumn Creators) one coming in the next few weeks - you may well find yourself back with the ‘faulty’ graphics driver…

1 Like

glad I found this thread. going to 32bit was the right move. 64bit was unuseably slow (as everyone in this thread knows). I’m giddy that I can now scroll through my albums in Roon.
hope this solution sticks for a while