Small streaming hickups

Dear Roon users and @support

I have only one small problem with roon: When a track starts it plays only one beat at the beginning, then one second nothing, and then it plays normally. No idea why, I use both local files and tidal streaming.

Now some details on my system:

i5 Intel NUC, 16 GB RAM, 256GB M.2 SSD, 2 TB 2.5" internal HDD, connected over LAN to the network

250/250 FTTH internet connection

BlueSound Pulse Flex connected over LAN

NAD C-368 with BluOS streaming module connected over LAN

Only the remotes (iPad mini 2, two iPhones) are connected over WiFi

Any ideas?

Thank you very much


PS: it doesn’t seem to do that every time. But almost every time when my playlist consists both local and Tidal files and I played several local tracks and then a Tidal track is coming up.

Hi @Michael_Wyden ----- Thank you for the report and my apologies for the troubles here.

Based on your feedback it sounds like you are receiving dropouts during playback. Our knowledge base has very good documentation on what can cause dropouts to occur and the best approach to handling them. Can you give the article a read and let me know what you’ve tried thus far?

Furthermore, I see you have provide some information about your home network. Thanks! May I very kindly ask you to please expand on this description and provide me the exact details of your network configuration/topology. Having some insight into any networking hardware you may be implementing in your setup would be helpful as well.


Hi @Eric

Thanks for getting in touch!

The NUC and all the harddiscs / ssds are new. I’ve read the KB article, but I still experience dropouts. But only in the beginning (for just some miliseconds) and only if I mix local files with tidal files. All local or all tidal works just fine.

In my office there’s the NUC with the Roon core, connected to a D-Link Switch, from there goes a 20m CAT5e LAN cable to the living room, connected to the Huawei FTTH modem.

The C-368 is connected via CAT5e LAN to the Huawei.

The Flex is connected via CAT5e to the same Switch as the NUC.

Hope that helps isolating the problem.

It’s not that big of a deal, I love Roon too much to bother with a few miliseconds of hickups (or say silence).

Plex streaming to the Philips Smart TV works just fine (from
the same NUC). So i don’t think it’s a network or Hardware problem.

I don’t do upsampling or DSP conversions

  • Michael

Hi @Michael_Wyden ---- Thank you for the follow up and taking the time to answer my questions. Both are appreciated! Moving forward, I would like to gather a bit more information from you in regard to this behavior you are experiencing. May I kindly ask you to please verify the following for me:

  1. Have you tried using the “resync delay” feature? If so, what was the experience like, the same or different?

  2. In regard to the “hiccups” you are noticing at the start of playback, when switching from track to track:

  • Do you find that codec/Sample rate is factor here? Looking for any patterns you are noticing.

  • Does it happen with the same local and TIDAL content each time?

  1. If you Play a local track and then add a TIDAL track to the queue do you notice the same behavior that your playlists are exhibiting?


Hi Eric,

thanks for your time and patience. I was in London for a few days to see The Who live in the Royal Albert Hall. It was awesome :slight_smile:

  1. Yes, I played around with it (100ms), but still the same result

  2. not really, no. But I’d guess it happens more with Tidal tracks, and I play mostly different stuff and it happens from time to time. It plays for a second, then stops, and then continues and doesn’t stop until the end. If the following track is also from the same source (Tidal or Local) it doesn’t happen again. But I can’t really see a pattern.

  3. Even if a play random tracks I see this happening, but not every time. But at least once or twice on a listening session (1-3hours)

  • Michael

PS: I just played 3 24/96 FLAC files without problems, next in Queue was an Jeff Beck interpretation of A day in the life streaming from Tidal, and the hiccups occour.

PPS: it does also happen when switching from two Tidal tracks in a row to a local track (FLAC 24/88.2)

Hi @Michael_Wyden ----- Thank you for following up with me and taking the time to answer my questions. Both are appreciated!

Moving forward, I would like to grab a set of logs from you to see if we can pinpoint what could be causing these hiccups to occur. Please reproduce the issue and note the time when the observation is made. Then following the instructions found here drop us a set of logs.


fwiw i had the same problem on a setup very similar to yours. after troubleshooting various things and getting nowhere i moved all my audio files onto an external SSD and all problems stopped + Roon performance increased noticeably.

Thanks Eric, I’ve sent you a private message with the logs.

thanks to you too Andy, but I really don’t want a new Harddisc, I bought that one especially for roon!

Hey @Michael_Wyden – I know Eric is still waiting on some feedback from our developers about the logs.

In the meantime, it would be an interesting test to know if @andybro’s theory has any merit in your setup. Is there a USB flash drive or another hard drive you can move some media over to and test with temporarily?

Most likely this is some kind of dropout, meaning the audio isn’t getting where it needs to fast enough. Often, troubleshooting this class of issues comes down to trial and error, meaning swapping cables, endpoints, routers, switches, etc, to see where the bottleneck is.

If you can run that test, it would help us eliminate one variable as a start. Thanks!

1 Like

Hi @mike

Thanks for getting in touch!

I’ll try this later. But as it not only lags with local, but also with Tidal tracks, I don’t be very optimistic about fixing that issue :slight_smile:

  • Michael

Hi there,

Seems like the NAD C-368 firmware update (Main, VFD and BT) did the trick. No hickups so far. BluOS MDC module was up2date, the Amp a few versions behind. I guess it was a compatibilty issue.

I’ll keep you posted, I hope it continues to work like the last few hours of playing. I really really love the radio feature. So great to play a few tracks and Roon fills in some tracks on it’s own

Thanks to @Eric and @mike for all their help and patience!

1 Like