SMB connection problem

So, everything was working fine, the SMB connection to my NAS (Netgear ReadyNAS) worked fine, library built and everything worked. Then Roon quit unexpectedly and when I turned it back on the connection didn’t work. Restarted the computer, no luck. Reinstalled the program, the library was altered, made the update, another library upgrade and everything was working fine again. Turned off Roon and turned it on again and again, “The network path was not found”.

And there’s nothing wrong with the NAS, iTunes works from it, Plex works, I can get to it through the finder fast and responsive. I’v never had any problems with dropouts or such

OSX El Capitain and the latest Roon software. The NAS was updated software wise this summer.

Hi Mikael,

Are you accessing your NAS in finder through SMB or AFP?

Just to do a quick check, in finder, try going to the menu -> Go -> Connect to Server and in the pop-up window writing smb://Your_NAS_name

replacing Your_NAS_name with the proper name to your music folder, something like smb://netgear316/music

Press connect and see if the contents comes up. If it does your smb service is working OK in the NAS. Try roon again now that you now the smb path is active.

This would be my first troubleshooting step anyway. If anyone else has other ideas, please jump in.

I’ve got both AFP and SMB set up and connecting with Roon through SMB.
smb://nas-C1-18-B2 (CIFS)._smb._tcp.local/media/Music
I tried the Go / Connect To Server and I get the folders and it works fine. I started Roon again and it still says “network path was not found”. I tried that earlier too with restarts and everything I could think of, re-entering the path in Roon, restarted the server, closed other apps accessing the server.

It’s a big folder (2300+ folders) so response time might be an issue? But while it worked, it worked really really well. So good I started questioning why iTunes is so sluggish in comparison.

All seems good in networking terms then. I guess the roon guys will probably want a look at your logs to see exactly about what is Roon complaining or maybe they have already an idea of what can cause this.

I’m pretty sure that Monday or so the Roonies will take care of you.

Hey @Mikael_Hagstrom – we had another user with a similar issue a few months back, and based on what we heard from him, the path you typed above may not be exactly right.

The original thread was here, and he eventually determined the issue to be the following:

I think we have a solution. When connecting the NAS, a program called connect music server became active. Roon then had a hard time deciphering the correct path. The IT guy got a solution which was using a path which ignores connect music server and then there is only one direct link to the music files on the NAS.

I’m not personally familiar with “Connect Music” but I’m going to check with the team and see if anyone has any ideas here. In the meantime, I would investigate something similar to what @Skywatcher mentioned above:

So I did some digging and it seems that running AFP and SMB at the same time is a bad idea

I switched off AFP and sure enough, after a reboot of the computer Roon works fine. It does however f**k up every other setup I’ve got with AFP. muted growling

Awhile back I decided to try Roon again and exported much of my SooLoos Library in native format to a USB drive. I don’t like anything dangling from my laptop so after a few days I connected the drive to a open port on my Apple Time Capsule. It took a bit of effort but I was finally able to have Roon see the drive and access the files using the SMB command. This worked nicely for some time but lately Roon cannot find the drive. Quite often Finder in OS X cannot see the drive either. Usually I have to plug the drive from the Time Capusule at which time the drive lights illuminates and I can “usually” find the drive.

Does anyone have a suggestion as to how to keep the drive mounted so when I open Roon I just don’t see my tagged Tidal files.?