SMB "Drive is full" error - Using IP fixes issue

Hi, I’m getting the same error – “Drive is full”. However I’m not using Dropbox, I’m saving to my Macbook Pro with plenty of space.

As an aside, randomly but consistently, Roon alerts me that a backup is failed because it can’t find a location that I previously set up successfully and was working fine. Nothing changed, except that Roon inexplicably can’t find the location anymore.

So I set up the backup using the same folder I was using before, with no issues. However this time, I’m getting this ‘drive full’ error which I’ve never encountered before. To troubleshoot, I set up a brand new folder to use as a backup (same laptop, same location, just different folder) and it gave me the same ‘drive full error’.

UPDATE
This might be a path or protocol issue. The ‘Drive full’ error was gotten when I set the backup path using a “smb://…” type path for the backup folder. I tried using an IP address to the same backup folder and everything backed up fine, no Drive Full error.

1 Like

hi @tholt,

What kind of storage location did you add that had this issue, can you provide some more information on the model/manufacturer of the storage location, the format of the drive and any relevant SMB settings you can share regarding it?

Roon should be able to backup to any drive that you were able to specify in Settings==>Backups, no excuses.

Thanks for finding, yet another, coding error in the Backup logic.

Hi @noris, the storage location is the HD of my Macbook Pro. It’s a SSD. See attached screenshot. It’s literally nothing more than the default laptop hard drive, so I can’t imagine that being the issue, or this would have come up for everyone using my version of a MBP.

Not sure what relevant SMB settings you’re referring to. I don’t want to share the path for security reasons. Suffice it to say, Roon accepted the path info and saw the backup folder I had created on this drive.

Thanks

Hi @tholt,

Apologies, but I am a bit confused here, since this is a local drive, how does the backup path fit into the issue?

Would you be comfortable sending a screenshot of your Roon Settings -> Storage setup to me via private message (click my name -> message)? That way it is in a more private setting.

Hi @noris , when I use a “smb” path, I get the ‘drive is full’ error. When I use an IP address as the path, I don’t get that issue. So on the surface, it would appear that the path type plays a part in this.

Will see about this.

1 Like