Software for the Pi4 with NAA functionality for HQPlayer

I am having a heck of a time getting the NAA image burned to an SD card, to actually work on my Pi4 that is currently running Ropiee without problems. I see that AudioLinux apparently has NAA functionality on their Pi4 image, but I have to pay 60 bucks to see if it works… Is there another software I can use that has the NAA functionality?


Dietpi has naa. BTW… I have audiolinux and the naa works there as well. Ropiee is easiest to use if you cannot get the Signalyst to work. I have used it many times on pi4. Diwnload. Burn to sd card with etcher. Insert. Power up. Wait a minute and search for it with hqplayer.

1 Like

For some reason that exact process is not working for me. I have tried two SD cards from two separate brands. Let me ask you a question though, when the NAA image from Signalyst is working and booted, do you have a flashing green light or just a red light?

There is just the red power light. With Ropieee there is a flashing green light. With a monitor attached I believe it takes you to login screen that you just ignore. The only way to see it is to open the preferences pane in HQPlayer. If I can help further please let me know or PM me. I prefer ropieeeXL for it’s flexibility and I cannot hear a difference.

1 Like

Thanks, I wanted to get DietPi running mainly so I could check whether or not I could connect to the NAA running from something other than the NAA image itself. I still can’t so that means something in my computer or network is preventing it and not the NAA image itself. I also found out that Ark, the included archiving and unarchiving software in Manjaro Linux isn’t properly unzipping 7z files. Of course, it didn’t give any indication of any errors, but the images when written weren’t working. After a lot of frustration I unzipped the image with 7z on a whim and it worked… Knowing that sooner would have prevented an awful lot of frustation.

I have DietPi running, at the moment with Roon Bridge until I can get sorted why I can’t connect to the NAA image. I have Ropiee on another SD card and first impressions are that Ropiee sounds better.

RoPieeeXL supports NAA.

1 Like

Thank you. I was able to get DietPi running and am currently using the NAA installed in it. The problem was that the program that comes in Manjaro Linux to deal with zip archives, Ark, was unzipping the 7p archives incorrectly, while not giving any indication it was doing so, instead appearing as if everything worked just fine. When I unzipped the image with 7p and then burned one of them, it worked perfectly. Ropiee doesnt come in a 7p archive, which is why it worked fine. I was completely out of ideas when I tried that though, just on a whim I decided, heck, what else can possibly go wrong…

I did not know that, thank you.