Software Not Running

Roon Core Machine

Nuc10I3, 8MB RAM, 256G SAMSUNG SSD

Networking Gear & Setup Details

TP Link AX3000.

Connected Audio Devices

None yet. I can’t get the core to work.

Number of Tracks in Library

Description of Issue

I have installed ROCK on a NUC and everything works as described until I get to the CODECS file. I put the file in the codec folder and can see it is there, but the Web Interface says Roon Software “Not Running” and a reboot does not change the outcome.

I ran into this when setting mine up. It seems to be some manner of file permissions issue, though I did not investigate it thoroughly. I primarily use linux as my os of choice and when transferring the codecs from my linux machine I had this problem. Eventually I did the same thing with the same files from a Windows machine and it took off and ran.

Thanks.

I don’t have access to a Windows machine unfortunately. I wonder if changing browsers might help?. Seems unlikely but I will give it a shot. I am so close to getting this going.

Don’t see a browser helping here. What os are you using?

Mac OS Monterey. I tried looking at the permissions, I have read and write, others have (Staff and Guests) read only.

I won’t be much use to you with a Mac. I suspect the issue is more of a permissions smb mask issue on the Nuc side of things. This issue has come up quite a bit in the past so I think there is a fair chance of your finding a solution by searching through the forums.

A different option would be be to install a linux based server on the Nuc and then Roon server on that. You would then have access to the file system and rights to change file permisssions. This was not my first choice because I just wanted it to be a set-it-and-forget-it appliance.

Thanks for your efforts. Maybe I can borrow a windows machine. I am looking for the appliance as well.

I will also keep looking at the forums.

Just to be clear, it is just a single ffmpeg file your are copying over to the Codecs directory, correct?

Did you fully extract the zipped ffmpeg file?
I think it needs extraction twice from memory…which gets fuzzy over time I admit…

1 Like

perhaps a screen shot of the file residing in the codecs folder of the ROCK directory structure might help us see what you have done.

1 Like

Here it is, I have tried using Unarchiver on it, but it does not unarchive.

Here is the file info:

I noticed it was locked and also tried an unlocked version to no avail.

I have a spare computer (HP ProDesk) for testing. I also have an iMac running macOS Monterey. I just installed ROCK on the HP computer and after a reboot a network device called “rock” appears on my internal network. From the Finder of the iMac I copied the ffmpeg file to the ROCK computer to the folder called Data/Codecs. In my case this is working fine. No issues with permissions. After a reboot it states "Roon Server Software OK. I don’t know what is going on in your situation, but I also did this install from a macOS Monterey machine.

I would try downloading the codec again, double checking the version. As mentioned, it takes 2 unzips (I use 7zip) to get to the file called ffmpeg. It is only this 1 file which needs to be copied to ROCK. ROCK’s storage permissions are preset and should not be an issue.

I used Unarchiver to open the download from the Johnvansickle site. It gives the FFMPEG file without another unzip. It is an executable file that I does not appear to be zipped and cannot be unzipped from Unarchiver.

Thanks. It all looks like it should work based on your description. I downloaded the file from the johnvansickle site, unarchived it and it had the ffmpeg file available. At that point did you unarchive ffmpeg fileagain? and if so, how? Once I see that file I cannot further unarchive it.

No, it is exactly like you describe. After the first unzip you already have a folder containing the ffmpeg file.

When you go to the Web GUI, do you see this?

If not, then a missing ffmpeg isn’t your problem.

Do you see this?

If you do then just hit “Start” and let’s see what happens next.

Don’t know what you mean by ‘a reboot’, but a Reboot is not the same as a 'Start" of the server software.

If you can’t ‘Start’ the server software then, because one can run ROCK with a missing codex, I suspect the ROCK install failed in some way.

1 Like

I get the second screen, but it will not “start”. Thanks for the tip and I see what you are thinking. I will go back through the BIOS and initial setup and see if I missed anything.

2 Likes

I finally got ROCk to run on the NUC10i3. I updated the BIOS, redid all the settings in the BIOs and ended up with the Software “Not Running” again.

Out of sheer frustration I hit the Operating System “Reinstall” and it reinstalled and sprang to life.

Not sure what made it finally work. Harder than I thought it would be. Nice to have it finally up and running.