Software update issue from roon core 1.7( build 571) to 1.8 (build 795)


I had a problem with my linux server to move from 1.7( build 571) to 1.8 (build 795)
To your information i’m not connecting my roon server every-time to the internet.
So that’s why i’m moving from a relative old version to newest version.
After update with Ipad as remote, my linux core roon disappeared from network and the server is not running anymore in the linux server…
I tried to relaunch the ./ script and install again the server on my linux server . it was the same. it appears that the script is retrieving from roon server not the last version but the 1,7 version…is it normal ?
may be your made an update of script ? Normally it should download the last version of roon core ?

let me know what do you think about my problem ?
see the screenshots, before and after updates
thanks in advance


You should be able to upgrade from within the application directly.
Make a backup before you upgrade.

There is a 1.8 installer as well you can download, but I recommend using the upgrade path seen in your screenshots.

Good luck with it.

thanks for you answer .
Yes surely, I tried to install with the ipad application but just after the upgrade with ipad, I can’t see anymore the core roon server on my linux server…
That’s why I used the script to install directly the linux version inside my server but it seems that the script is installing all the time the 1.7 version. and again and again I have the problem to move from 1.7 to 1.8…
Are you sure that the last version is installed with the script ?
let me know

I have no idea if that script will pull 1.7 or 1.8. It looks like the script name doesn’t change.
delete it and start fresh.

here is the link for the install how-to.

service roonserver status will tell you what is running.
service roonserer stop
service roonserver start