Software upgrade to 1.8 unable to open roon [Solved: update remote devices]

Roon Core Machine\

Roon nuclues

Networking Gear & Setup Details

SOTM ethernet swtich
roon nuclues
enthernet no wireless
windows 10 lenovo laptop

Connected Audio Devices

USB with Roon Nucleus and Windows 10 lenovo laptop with latest windows 10

Library Size

Not sure, not very large

Description of Issue

Open roon and it say there was a update available, click on update, roon did not resume, when I tried to open it again, the icon shows for 2 seconds then closes

Delete your Roon remotes and reinstall them. That worked for me and others.

1 Like

Thanks for the reply Sammie, I only have the one remote on the Windows 10 laptop, if I understand correctly, are you saying I just delete the Roon windows application and reload it?

Kind regards

Yes, do that.

Thanks Sammie. Your suggestion worked. Have a great weekend.
Kind Regards

Had the same, didn’t delete the old one, just re-installed to same location and it just overwrites it. It worked.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.